hdu3466_01背包变形 理解无后效性

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5607    Accepted Submission(s): 2368


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 
题意:普通01背包,但是每个物品除了价格和价值以外还加了一个限制条件SMALLi,只有现在的钱数大于SMALLi的时候才能够购买。
思路:看了一下大牛们都提到了无后效性,想了一想,有点顿悟了。物品按照small-cost排序由小到大排序,因为当small<cost时就是01背包,当small>cost时,相当于0 ~ small-cost的dp不能正常更新,但是small-cost之后的dp还是可以继续正常更新的。也就是说,我们先把small-cost最小的放进去,因为后来的物品一定无法影响到此时small-cost以前的,所以这个物品放入的时候一定无后效性,反之,如果先放入small-cost大的,他无法保证小的small-cost之后的能够被更新到最优状态,所以无法完成DP。
#include<bits/stdc++.h>
using namespace std;
int dp[5500];
struct K{
    int cost;
    int value;
    int small;
}the[550];
bool cmp(K a, K b){
        return a.small-a.cost < b.small-b.cost;
}
int main(){
    int n,total;
    while(scanf("%d%d",&n,&total) == 2){
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++)
             scanf("%d%d%d",&the[i].cost,&the[i].small,&the[i].value);
        sort(the+1,the+1+n,cmp);
        for(int i = 1; i <= n; i++)
            for(int j = total; j >= max(the[i].cost,the[i].small); j--){
                dp[j] = max(dp[j],dp[j-the[i].cost]+the[i].value);
            }
        printf("%d\n",dp[total]);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值