题解:HDU 2717: Catch That Cow (BFS)

上题目

Problem Description Farmer John has been informed of the location of a
fugitive cow and wants to catch her immediately. He starts at a point
N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤
K ≤ 100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long
does it take for Farmer John to retrieve it?

Input Line 1: Two space-separated integers: N and K

Output Line 1: The least amount of time, in minutes, it takes for
Farmer John to catch the fugitive cow.

Sample Input 5 17

Sample Output 4

Hint The fastest way for Farmer John to reach the fugitive cow is to
move along the following path: 5-10-9-18-17, which takes 4 minutes.

翻译

初始值为i 终点j

你所能进行的移动是 ±1 或者 乘2

问从i 到j 的最短路径问题

分析

标准的bfs(求最短路径)

不过我们可以设置i > 0; j < 0

然后对于 +1; - 1; * 2 三种情况依次压栈

求到达j点的最小操作次数

上代码 + 注释

#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

int vis[100000];
int flag, start, endd;
struct k{//用来存储当前的位置和步数
    int x;
    int countt;
};

int bfs()
{
    memset(vis, 0, sizeof(vis));
    queue <k>q;
    k now, next;
    now.countt = 0;
    now.x = start;
    q.push(now);
    while (!q.empty())
    {
        now = q.front();
        q.pop();
        if (now.x == endd)
            return now.countt;
        if (now.x < 0 || now.x > 1000000)//出界
            continue;
        if (vis[now.x] == 1)//已经被访问
            continue;
        vis[start] = 1;
        vis[now.x] = 1;
        next.x = now.x - 1;//向 -1 方向移动
        next.countt = now.countt + 1;
        q.push(next);
        next.x = now.x + 1;//向 +1 方向移动
        next.countt = now.countt + 1;
        q.push(next);
        next.x = now.x * 2;//向 * 2 方向移动
        next.countt = now.countt + 1;
        q.push(next);
    }//直至队列为空
}

int main(void)
{
    while (scanf("%d %d", &start, &endd) != EOF)
    {
        int cnt;
        cnt = bfs();
        printf("%d\n", cnt);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
你好!对于扫雷游戏的题解,我可以给你一些思路和代码示例。首先,你需要了解扫雷游戏的规则和要求。接下来,你可以使用C++语言来实现游戏逻辑和界面。 下面是一个简单的扫雷游戏的C++代码示例: ```cpp #include <iostream> #include <vector> #include <random> using namespace std; class MinesweeperGame { private: int rows; int cols; vector<vector<char>> board; vector<vector<bool>> revealed; vector<pair<int, int>> directions = {{-1, -1}, {-1, 0}, {-1, 1}, {0, -1}, {0, 1}, {1, -1}, {1, 0}, {1, 1}}; public: MinesweeperGame(int m, int n, int mineCount) { rows = m; cols = n; board.resize(rows, vector<char>(cols, ' ')); revealed.resize(rows, vector<bool>(cols, false)); placeMines(mineCount); calculateNumbers(); } void printBoard() { cout << " "; for (int j = 0; j < cols; j++) { cout << j << " "; } cout << endl; for (int i = 0; i < rows; i++) { cout << i << " |"; for (int j = 0; j < cols; j++) { cout << board[i][j] << "|"; } cout << endl; } } bool isGameOver() { for (int i = 0; i < rows; i++) { for (int j = 0; j < cols; j++) { if (board[i][j] == 'M' && revealed[i][j]) { return true; } } } return false; } void reveal(int row, int col) { if (row < 0 || row >= rows || col < 0 || col >= cols || revealed[row][col]) { return; } revealed[row][col] = true; if (board[row][col] == 'M') { return; } if (board[row][col] == '0') { for (auto dir : directions) { reveal(row + dir.first, col + dir.second); } } } private: void placeMines(int mineCount) { random_device rd; mt1

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值