周赛 1009 题解 hdu 2717 Catch That Cow (简单bfs)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6016    Accepted Submission(s): 1914


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.



题意:

你在s点,奶牛在e点,奶牛不动,你每次能从x到x+1或x-1或2*x,要抓住奶牛,问最小步数。


思路:

bfs,利用一个队列,每次出队首nx,按照上述三种方法扩展节点tx,如果tx没有入队列,则入队列,直到e点入队列,这样能保证每一个点都能以最小的步数入队列,就能得到正确答案了。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 100005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,cnt,tot,flag;
int vis[MAXN];  // 标记数组 并且记录每个点的步数

void bfs()
{
    int i,j,t;
    queue<int>q;  // STL中的队列 当然也可以手写
    memset(vis,-1,sizeof(vis)); // 初始化为-1
    vis[n]=0; // 起点0步可以到达
    q.push(n); // 起点入队
    while(!q.empty()) 
    {
        int nx=q.front(); // 取出队首
        q.pop(); // 队首出队
        if(nx==m) // 如果为m 则找到奶牛
        {
            ans=vis[m];
            return ;
        }
        if(nx>0&&vis[nx-1]==-1)  // 扩展tx
        {
            int tx=nx-1;
            vis[tx]=vis[nx]+1;
            q.push(tx);
        }
        if(nx<=100000&&vis[nx+1]==-1)  // 扩展tx
        {
            int tx=nx+1;
            vis[tx]=vis[nx]+1;
            q.push(tx);
        }
        if(2*nx<=100000&&vis[2*nx]==-1)  // 扩展tx
        {
            int tx=nx*2;
            vis[tx]=vis[nx]+1;
            q.push(tx);
        }
    }
}
int main()
{
    int i,j,t;
    while(~scanf("%d%d",&n,&m))
    {
        bfs();
        printf("%d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值