POJ 2406 Power Strings KMP

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 31707 Accepted: 13206

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


输入最后有个 .  (点)才算输入结束。
题目意思就是找周期,然后算出给的字符串由几个周期组成,即n.
算周期可以不用KMP,直接枚举周期,但字符串长度除以周期得是一个整数,这样可以排除好多情况。
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char s[1000010];
int T;
int main()
{
   while ( scanf("%s",s)!=EOF)
  {
       if(strcmp(s,".")==0)
        break;
    int  len=strlen(s);
    for(int i=1;i<=len;i++)//枚举周期i,
        {
           if(len%i==0)//i要能被len整除才行,
            {
               int ok=1;
               for(int j=1;j<len;j++)
                 if(s[j]!=s[j%i])
                        {ok=0;break;}
                 if(ok){ T=i;break;}//得到最小的周期,然后len除之,就可以得到n了。

            }
        }
  printf("%d\n",len/T);
  }
 return 0;
}

还有KMP的算法。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[1000005];
int next[1000005];
int l;
void getnext()
{
	int j=0,k=-1;
	next[0]=-1;
	while(j<l)
	{
		if(k==-1 || s[j]==s[k])
		{
			j++;k++;
			if(s[j]!=s[k])
				next[j]=k;
			else
				next[j]=next[k];
		}
		else k=next[k];
	}
}
int main()
{
	int ans;
	while(scanf("%s",s) && strcmp(s,"."))
	{
		ans=1;
		l=strlen(s);
		getnext();
		if(l%(l-next[l])==0)
			ans=l/(l-next[l]);
		cout<<ans<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值