hdu1395 2^x mod n = 1

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12312    Accepted Submission(s): 3848


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

Sample Input
  
  
2 5
 

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1
#include<stdio.h>
int main()
{
	int x,t,n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==1||n%2==0)
		printf("2^? mod %d = 1\n",n);
		else
		{
			x=1;
			t=2;
			while(t%n!=1)
			{
				x++;
				t=t*2%n;
			}
			printf("2^%d mod %d = 1\n",x,n);
		}
	}
	return 0;
}

题目中给出输入一个整数n,要求一个最小整数的x,使得2^x mod n=1;

根据模P乘法逆元:对于整数a、p如果存在整数b,满足a*b mod p=1则称b是a的模P乘法逆元。

a存在模P的乘法逆元的充要条件是gcd(a,p)=1,令a=2^x,b=1,p=n

则若存在x使用2^x mod n=1则gcd(2^x,n)=1

(1)因为要求x的值大于0。则2^x的因子中只有一个2,所以当n为偶数时gcd(2^x,n)=2k(k=1,2,3...),即此时不存在x使得2^x mod n=1。

(2)当n为奇数时gcd(2^x,n)=1,则必存在x使得2^x mod n=1。

(3)由于任何数模1的结果为0,所以当n=1时,无论x取何值,2^x mod n=0.

综合上述(1),(2),(3),当n的值为1或偶数时,不存在x使得2^x mod n=1,其它情况则必存在一x使得2^x mod n =1。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值