poj 1064 Cable master(二分)

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25331 Accepted: 5440

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source




题意:有N 条绳子,长度分别是Li。如果从他们中切割出k 条长度相等的绳子的话,这k条绳子每条最长有多长?
答案保留两位小数。
限制条件:
1<=N<=10000
1<=K<=10000
1<=Li<=100000

思路:
另 条件C(x):可以得到K条长度为x的绳子,问题要求满足条件C(x)的最大x
则C(x)=(floor(Li/x)的总和是否大于等于K)



这道题用C++过了,G++不过。
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 1000000
int n,k;
double L[10005];
bool C(double x)
{
	int num=0;
	for(int i=0;i<n;i++)
	num+=(int)(L[i]/x);
	return num>=k;
}
void solve()
{
	int i;
	double low,high,mid;
	low=0.0;
	high=INF;
	for(i=0;i<100;i++)
	{
		mid=(low+high)/2;
		if(C(mid)) low=mid;
		else high=mid;
	}
	printf("%.2lf\n",floor(high*100)/100);
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		for(int i=0;i<n;i++)
		scanf("%lf",&L[i]); 
		solve();
	} 	
	return 0;
}




/
二分搜索的阶数判定:
在输出小数的问题中,一般都会指定允许的误差范围或者是指定输出中小数点后面的位数。
因此在使用二分搜索时,有必要设置合理的结束条件,来满足精度的要求。在上面的程序中,
我们指定了循环次数作为终止条件。1次循环可以把区间的范围缩小一半,100次循环可以 达到
10的负30次幂的精度范围,基本上是没哟问题的。除此之外,也可以把终止条件设置为像(high-low)>EPS这样
指定一个区间的大小。在这种情况下,如果EPS取得太小了,就有可能会因为浮点小数精度的原因导致陷入死循环,
因此要小心。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值