hdu1023Train Problem II(大数、卡特兰数)

29 篇文章 4 订阅
7 篇文章 0 订阅

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11280    Accepted Submission(s): 5978


http://acm.hdu.edu.cn/showproblem.php?pid=1023

Problem Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

 

 

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

 

 

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

 

 

Sample Input

1

2

3

10

 

 

Sample Output

1

2

5

16796

题意:1-n依次进栈,有多少个出队序列。

思路:卡特兰数http://www.cnblogs.com/kuangbin/archive/2012/03/21/2410516.html

             f[n]=(4n-2)*f[n-1]/(n+1)

这个题用Java大数做比较方便些。。。初学Java,有点小激动~~~

拓展:

大数加法:big1.add(big2);
大数减法:big1.subtract(big2);
大数乘法:big1.multiply(big2);
大数除法:big1.divide(big2);

代码:

import java.util.*;
import java.math.*;

public class train {
	public static void main(String[] args) {
		BigInteger f[]=new BigInteger[105];
		int n;
		Scanner cin=new Scanner(System.in);
		while(cin.hasNext()) {
			n=cin.nextInt();
			BigInteger b=BigInteger.valueOf(1);
			f[1]=b;
			for(int i=2;i<=n;i++) {
				int s1=4*i-2;
				BigInteger s2=BigInteger.valueOf(s1);
				f[i]=s2.multiply(f[i-1]);
				int s3=i+1;
				BigInteger s4=BigInteger.valueOf(s3);
				f[i]=f[i].divide(s4);
				
			}
			System.out.println(f[n]);
		}
		cin.close();
		
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值