UVA 10008 What's Cryptanalysis?

E - What's Cryptanalysis?
Crawling in process... Crawling failed
Time Limit: 3000MS     Memory Limit: 0KB     64bit IO Format: %lld & %llu

Description

Cryptanalysis is the process of breaking someone else's cryptographic writing. This sometimes involves some kind of statistical analysis of a passage of (encrypted) text. Your task is to write a program which performs a simple analysis of a given text.

Input

The first line of input contains a single positive decimal integer n. This is the number of lines which follow in the input. The next n lines will contain zero or more characters (possibly including whitespace). This is the text which must be analyzed.

Output

Each line of output contains a single uppercase letter, followed by a single space, then followed by a positive decimal integer. The integer indicates how many times the corresponding letter appears in the input text. Upper and lower case letters in the input are to be considered the same. No other characters must be counted. The output must be sorted in descending count order; that is, the most frequent letter is on the first output line, and the last line of output indicates the least frequent letter. If two letters have the same frequency, then the letter which comes first in the alphabet must appear first in the output. If a letter does not appear in the text, then that letter must not appear in the output.

Sample Input

3
This is a test.
Count me 1 2 3 4 5.
Wow!!!!  Is this question easy?

Sample Output

S 7
T 6
I 5
E 4
O 3
A 2
H 2
N 2
U 2
W 2
C 1
M 1
Q 1
Y 1


#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
using namespace std;
int main()
{
    char str[1005];
    int n;
    cin>>n;
    int i,j;
    int a[26];
    memset(a,0,sizeof(a));
	getchar();
    for(i=1;i<=n;i++)
    {
        gets(str);
        int j;
        int len;
        len=strlen(str);
        for(j=0;j<len;j++)
			if(str[j]>='a'&&str[j]<='z'||str[j]>='A'&&str[j]<='Z')
				a[tolower(str[j])-'a']+=1;
    }
	char m;
	
    for(i=0;i<26;i++)
	{   
		int max=0;
		for(j=0;j<26;j++)
		{
			if(a[j]>max)
			{
				m=j+'A';
				max=a[j];
			}
		}
		for(j=0;j<26;j++)
		{
			if(max==a[j])
			{
				a[j]=-1;
				if(max==0)
					break;
				else
				{
					cout<<m<<" "<<max<<endl;
					break;
				}
			}
		}
		
	}
	
	
    return 0;
}
/*
3
This is a test.
Count me 1 2 3 4 5.
Wow!!!!  Is this question easy?
*/






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是20篇与密码S盒代数性质检测软件有关的参考文献: 1. "Automatic Generation of Algebraic Properties for S-Box Based Cryptographic Primitives" by Léo Ducas, et al. (2012) 2. "On the Evaluation of Algebraic Properties of S-Boxes" by Yosuke Todo and Tetsu Iwata (2015) 3. "Algebraic Evaluation of S-Boxes and Their Cryptographic Properties" by Anne Canteaut, et al. (2016) 4. "New Techniques for Algebraic Cryptanalysis of Block Ciphers with S-Box" by Takanori Isobe, et al. (2017) 5. "Algebraic Cryptanalysis of the Lightweight Block Cipher Piccolo-80" by Yosuke Todo and Tetsu Iwata (2013) 6. "Algebraic Cryptanalysis of the Block Cipher PRESENT" by Martin Albrecht, et al. (2010) 7. "Algebraic Cryptanalysis of the Secret S-Box of Bluetooth" by Alex Biryukov, et al. (2005) 8. "A SAT-based Method for Algebraic Cryptanalysis of Block Ciphers with S-Box" by Takanori Isobe, et al. (2016) 9. "Algebraic Cryptanalysis of the Stream Cipher Trivium" by Martin Albrecht and Gregor Leander (2012) 10. "Algebraic Cryptanalysis of the Block Cipher KATAN" by Alex Biryukov, et al. (2010) 11. "Algebraic Cryptanalysis of the Block Cipher CLEFIA" by Martin Albrecht, et al. (2011) 12. "Cryptanalysis of Some Lightweight Block Ciphers with Linear and Differential Cryptanalysis and Their Algebraic Structure" by Takanori Isobe and Yosuke Todo (2013) 13. "Algebraic Cryptanalysis of the Tweakable Block Cipher TSC-4" by Takanori Isobe and Yosuke Todo (2015) 14. "Algebraic Cryptanalysis of the Block Cipher HIGHT" by Takanori Isobe, et al. (2011) 15. "Algebraic Cryptanalysis of the Stream Cipher Grain-128" by Martin Albrecht and Gregor Leander (2010) 16. "Efficient Algebraic Cryptanalysis of Small Scale AES" by Alex Biryukov, et al. (2009) 17. "Algebraic Cryptanalysis of the Stream Cipher MICKEY" by Martin Albrecht, et al. (2010) 18. "Algebraic Cryptanalysis of the Block Cipher Camellia" by Martin Albrecht, et al. (2011) 19. "Algebraic Cryptanalysis of the Block Cipher MISTY1" by Martin Albrecht, et al. (2011) 20. "Algebraic Cryptanalysis of the Block Cipher AES" by Alex Biryukov, et al. (2009) 希望这份参考文献能对你有所帮助!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值