杭电ACM1005 C做法

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 173466    Accepted Submission(s): 42860


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 
脑子锈了不少,简单的题目都要想不少时间了。。。参考了其他大神的一些想法,贴个网址
http://blog.csdn.net/middle544291353/article/details/7723427
余数出现的循环周期为7*7=49次,因此我直接将需要输出的n%49,这样只要计算一次49个数,之后出现的到之前数组找就行,有看到大神用long int类型,我用的是int类型也AC了,直接贴代码吧

#include<stdio.h>
int main()
{
	int a,b,n;
	int f[100];
	f[1] = 1,f[2] = 1;
	while(scanf("%d%d%d",&a,&b,&n)!=EOF&&(a!=0)&&(b!=0)&&(n!=0))
	{
		if(n==1||n==2) printf("1\n");
		else
		{
			n %= 49;
			for(int i=3;i<=n;i++)
			{
				f[i] = (a*f[i-1]+b*f[i-2])%7;	
			}
			printf("%d\n",f[n]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值