HDOJ1059 Dividing

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28131    Accepted Submission(s): 8084


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
  这个题目可以使用暴力法来解决,但也不完全是暴力的,技巧写在注释。
也可以使用多重背包来解。
import java.util.Scanner;
public class Main{
	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		int count = 1;
		while (scanner.hasNext()) {
			int arr[] = new int[6];
			for (int i = 0; i < arr.length; i++) {
				arr[i] = scanner.nextInt();
			}
			if(arr[0]==0&&arr[1]==0&&arr[2]==0&&arr[3]==0&&arr[4]==0&&arr[5]==0){
				break;
			}
			/*
			所有数字只要它出现次数超过6次,超过的偶数次就先分配掉,剩下的用6个for循环求和,
			如果能组合出总和的一半这种情况,就表示可以等分两组数字,否则不能
			*/
			int sum = 0;
			for (int i = 0; i < arr.length; i++) {
				if(arr[i]>6)arr[i] = (arr[i]%2==1?7:6);//原来是奇数还是奇数,原来是偶数还是偶数
				sum+= arr[i]*(i+1);
			}
			System.out.println("Collection #" + count + ":");
			count++;
			/*总和如果为奇数就不用算直接是不能等分了*/
			if(sum%2 != 0){
				System.out.println("Can't be divided.");
				System.out.println();//Output a blank line after each test case.
				continue;
			}
			sum /= 2;
			boolean isOK = false;
			XB: for (int i1 = 0; i1 <= arr[0]; i1++) {
				for (int i2 = 0; i2 <= arr[1]; i2++) {
					for (int i3 = 0; i3 <= arr[2]; i3++) {
						for (int i4 = 0; i4 <= arr[3]; i4++) {
							for (int i5 = 0; i5 <= arr[4]; i5++) {
								for (int i6 = 0; i6 <= arr[5]; i6++) {
									if (sum == i1+i2*2+i3*3+i4*4+i5*5+i6*6) {
										isOK = true;
										break XB;
									}
								}
							}
						}
					}
				}
			}
			if (isOK) {
				System.out.println("Can be divided.");
			} else {
				System.out.println("Can't be divided.");
			}
			System.out.println();
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值