ZOJ - 3777 —— Problem Arrangement —— 状态压缩DP


The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to Mpoints, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution


题意是说在比赛中,把简单的题目放在前面可能会使得分数提高,相反将难一点的题目放在前面的话有可能导致没有时间去做后面容易的题目了。

这道题是问有T组数据,然后有n道题目,再给你一个整数m。

接下来是n阶方阵,代表着第i道题放在第j个位置时最后可以得多少分。最终输出的其实是一个期望的值,用一共有的情况比上有多少种情况会 >= m。

其实总的情况书也就是n的阶乘啦。最后如果不能达到m,则输出"No solution".

思路:状态压缩dp.

dp[i][j] 代表的是集合i中可以达到分值为j的次数。

所以说dp[(1<<n)-1][m]就是代表最后所有的集合中最终分值可以达到m的个数。。


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>

using namespace std;

#define MAX_N 100005
#define INF 0x3f3f3f3f
#define Mem(a,x) memset(a,x,sizeof(a))
#define ll long long

int score[15][15],dp[1<<15][505];
int sum[15];
void init() {
    sum[1] = 1;
    for(int i = 2; i<=14; i++) {
        sum[i] = sum[i-1]*i;
    }
    return ;
}
int gcd(int a,int b) {
    if(b == 0) return a;
    return gcd(b,a%b);
}
int main()
{
    int k;
    cin>>k;
    init();
    while(k--) {
        int n,m;
        cin>>n>>m;
        for(int i = 1; i<=n; i++) {
            for(int j = 0; j<n; j++) {
                scanf("%d",&score[i][j]);
            }
        }
        Mem(dp,0);
        dp[0][0] = 1;
        for(int i = 0; i<(1<<n); i++) {
            int con = 0;
            for(int j = 0; j<n; j++) {
                if(i&(1<<j)) con ++;
            }
            for(int l = 0; l<n; l++) {
                    if(i&(1<<l)) continue;
                for(int k = 0; k<=m; k++) {
                    int tmp = k+score[con + 1][l];
                    if(tmp >= m) {
                        dp[i|(1<<l)][m] += dp[i][k];
                    }
                    else dp[i|(1<<l)][tmp] += dp[i][k];
                }
            }
        }
        if(dp[(1<<n)-1][m] == 0) {
            cout<<"No solution"<<endl;
            continue;
        }
        int cur = gcd(dp[(1<<n)-1][m],sum[n]);
        int ans = sum[n]/cur,ans1 = dp[(1<<n)-1][m]/cur;
        cout<<ans<<"/"<<ans1<<endl;
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值