poj 3070 Fibonacci

16 篇文章 0 订阅
7 篇文章 0 订阅
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11123 Accepted: 7913

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

题意:给你一个求解第N个斐波那契数的公式。 让你求出Fn % 10000。

#include <iostream>
#include <string.h>
using namespace std;
struct matrix
{
    long long e[2][2];
};
int n,mod=10000;
matrix matrix_mul(matrix a,matrix b)
{
    matrix sum;
    memset(sum.e,0,sizeof(sum.e));
    for(int i=0;i<2;++i)
        for(int j=0;j<2;++j)
        for(int k=0;k<2;++k)
        if(a.e[i][k]&&b.e[k][j])
        sum.e[i][j]=(sum.e[i][j]+a.e[i][k]*b.e[k][j])%mod;
        return sum;
}
long long matrix_pow()
{
    matrix s,ee;
    ee.e[0][0]=ee.e[1][1]=1;
    ee.e[0][1]=ee.e[1][0]=0;
    s.e[0][0]=s.e[0][1]=s.e[1][0]=1;
    s.e[1][1]=0;
    while(n)
    {
        if(n&1)
            ee=matrix_mul(ee,s);
        n>>=1;
        s=matrix_mul(s,s);
    }
    return ee.e[1][0];//为什么矩阵中处于【1】【0】这个位置的值就是所要的结果还不理解
//今天重新来看一下这个斐波那契,这个[0][1]和[1][0]位置的数值其实都是fn,在关系试中也可以看出来
}

int main()
{
    while(cin>>n,n!=-1)
    {
        if(n==0||n==1)
            cout<<n<<endl;
        else
            cout<<matrix_pow()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值