Six Degrees of Cowvin Bacon poj 2139

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4

Sample Output

100

n头奶牛,m部电影,每部电影告诉你是哪几头奶牛.如果两头奶牛在一起出演就相互度=1,如果两头奶牛没有一起出演过,但是同时跟第三头奶牛出演过,那么这两头奶牛的相互度就等于他们与第三头奶牛的相互度之和。要求输出牛的最小平均分开度的100倍。

数据量又小,所以用Floyd

#include <cstdio>
#include <cstring>
const int maxn = 300 + 5;
const int inf = 1<<29;
int n, m;
int f[maxn][maxn];
int a[maxn];
void floyd()
{
    int i, j, k;
    for(k=1; k<=n; ++k)
        for(i=1; i<=n; ++i)
            for(j=1; j<=n; ++j)
                if(f[i][j]> f[i][k] + f[k][j])
                    f[i][j] = f[i][k] + f[k][j];
}
int main()
{
    int i, j, k, ans, ret;
    while(~scanf("%d%d",&n, &m)) {
        for(i=0; i<=n; ++i) {
            for(j=0; j<=n; ++j) f[i][j] = inf;
            f[i][i] = 0;
        }
        while(m--) {
            scanf("%d", &k);
            for(i=0; i<k; ++i) {
                scanf("%d", &a[i]);
                for(j=0; j<i; ++j)
                    f[a[i]][a[j]] = f[a[j]][a[i]] = 1;
            }
        }
        floyd();
        ans = inf;
        for(i=1; i<=n; ++i) {
            ret = 0;
            for(j=1; j<=n; ++j)
                ret += f[i][j];
            if(ans > ret) ans = ret;
        }
        printf("%d\n", ans*100/(n-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值