Buy Tickets POJ - 2828

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 200005
int sum[maxn<<2];
int ans[maxn];
struct NODE
{
    int pos,val;
}node[maxn];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build_tree(int l,int r,int rt)
{
    sum[rt]=r-l+1;
    if(l==r)
    {
        return ;
    }
    int m=(l+r)>>1;
    build_tree(lson);
    build_tree(rson);
    pushup(rt);
}
void update(int p,int val,int l,int r,int rt )
{
    if(l==r)
    {
        sum[rt]=0;
        ans[l]=val;
        return ;
    }
    --sum[rt];
    int m=(l+r)>>1;
    if(p>=sum[rt<<1])
        update(p-sum[rt<<1],val,rson);
    else
        update(p,val,lson);
    pushup(rt);
}
int main()
{
    int n;
    while(cin>>n)
    {
        build_tree(0,n-1,1);
        for(int i=0;i<n;++i )
        {
            scanf("%d%d",&node[i].pos,&node[i].val);
        }
        for(int i=n-1;i>=0;--i)
        {
            update(node[i].pos,node[i].val,0,n-1,1);
        }
        for(int i=0;i<n;++i)
        {
            //int a=ans[i]?
            //cout<<ans[i]<<' ';
            //printf("%d")
            printf("%d%c",ans[i],(i==n-1)?'\n':' ');
        }

    }
    return 0;
}
/*开始想这道题觉得倒着处理比较方便,然后就套着线段树的模板就往上敲,还想着用在遇到线段树中的每个节点的时候,把每个节点(要插入的位置)都建立一个stack来保存由不同顺序插入到这个位置的人,最后写着写着就发现感觉线段树维护的东西变味了,最后写完,果真gg
然后去请教大佬,
发现:
对每一组数据像
0 77
1 51
1 33
2 69
1 44
3 62
2 22
还是逆序处理对于22最终确定的位置,要求他前面必须有2个空位置
                62最终确定的位置,要求他前面必须有3个空位置
                ...
                77最终确定的位置,要求他前面必须有0个空位置
空格的个数也就是这个数要在的位置
那么线段树维护的就是每个区间空格的个数了,

*/







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值