UVa 10194 Football (aka Soccer) (模拟)

10194 - Football (aka Soccer)

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=98&page=show_problem&problem=1135

The Problem

Football the most popular sport in the world (americans insist to call it "Soccer", but we will call it "Football"). As everyone knows, Brasil is the country that have most World Cup titles (four of them: 1958, 1962, 1970 and 1994). As our national tournament have many teams (and even regional tournaments have many teams also) it's a very hard task to keep track of standings with so many teams and games played!

So, your task is quite simple: write a program that receives the tournament name, team names and games played and outputs the tournament standings so far.

A team wins a game if it scores more goals than its oponent. Obviously, a team loses a game if it scores less goals. When both teams score the same number of goals, we call it a tie. A team earns 3 points for each win, 1 point for each tie and 0 point for each loss.

Teams are ranked according to these rules (in this order):

  1. Most points earned.
  2. Most wins.
  3. Most goal difference (i.e. goals scored - goals against)
  4. Most goals scored.
  5. Less games played.
  6. Lexicographic order.

The Input

The first line of input will be an integer N in a line alone (0 < N < 1000). Then, will follow N tournament descriptions. Each one begins with the tournament name, on a single line. Tournament names can have any letter, digits, spaces etc. Tournament names will have length of at most 100. Then, in the next line, there will be a number T (1 < T <= 30), which stands for the number of teams participating on this tournament. Then will follow T lines, each one containing one team name. Team names may have any character that have ASCII code greater than or equal to 32 (space), except for '#' and '@' characters, which will never appear in team names. No team name will have more than 30 characters.

Following to team names, there will be a non-negative integer G on a single line which stands for the number of games already played on this tournament. G will be no greater than 1000. Then, G lines will follow with the results of games played. They will follow this format:

team_name_1#goals1@goals2#team_name_2
For instance, the following line:
Team A#3@1#Team B
Means that in a game between Team A and Team B, Team A scored 3 goals and Team B scored 1. All goals will be non-negative integers less than 20. You may assume that there will not be inexistent team names (i.e. all team names that appear on game results will have apperead on the team names section) and that no team will play against itself.

The Output

For each tournament, you must output the tournament name in a single line. In the next T lines you must output the standings, according to the rules above. Notice that should the tie-breaker be the lexographic order, it must be done case insenstive. The output format for each line is shown bellow:

[a]) Team_name [b]p, [c]g ([d]-[e]-[f]), [g]gd ([h]-[i])
Where:
  • [a] = team rank
  • [b] = total points earned
  • [c] = games played
  • [d] = wins
  • [e] = ties
  • [f] = losses
  • [g] = goal difference
  • [h] = goals scored
  • [i] = goals against
There must be a single blank space between fields and a single blank line between output sets. See the sample output for examples.

Sample Input

2
World Cup 1998 - Group A
4
Brazil
Norway
Morocco
Scotland
6
Brazil#2@1#Scotland
Norway#2@2#Morocco
Scotland#1@1#Norway
Brazil#3@0#Morocco
Morocco#3@0#Scotland
Brazil#1@2#Norway
Some strange tournament
5
Team A
Team B
Team C
Team D
Team E
5
Team A#1@1#Team B
Team A#2@2#Team C
Team A#0@0#Team D
Team E#2@1#Team C
Team E#1@2#Team D

Sample Output

World Cup 1998 - Group A
1) Brazil 6p, 3g (2-0-1), 3gd (6-3)
2) Norway 5p, 3g (1-2-0), 1gd (5-4) 
3) Morocco 4p, 3g (1-1-1), 0gd (5-5)
4) Scotland 1p, 3g (0-1-2), -4gd (2-6)

Some strange tournament
1) Team D 4p, 2g (1-1-0), 1gd (2-1)
2) Team E 3p, 2g (1-0-1), 0gd (3-3)
3) Team A 3p, 3g (0-3-0), 0gd (3-3)
4) Team B 1p, 1g (0-1-0), 0gd (1-1)
5) Team C 1p, 2g (0-1-1), -1gd (3-4)

无脑模拟。

注意比较队名时忽略大小写。


完整代码:

/*0.019s*/

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

char tournament[105];
string name1, name2, goals1, goals2;

struct node
{
	char name[35];
	int point, played, win, tie, loss, diff, scored, against;
	///分,场数,胜,平,负,净胜球,进球,失球
	bool operator < (const node a)const
	{
		if (point >= a.point)
		{
			if (point > a.point) return true;
			if (win >= a.win)
			{
				if (win > a.win) return true;
				if (diff >= a.diff)
				{
					if (diff > a.diff) return true;
					if (scored >= a.scored)
					{
						if (scored > a.scored) return true;
						if (played <= a.played)
						{
							if (played < a.played) return true;
							return strcasecmp(name, a.name) < 0;
						}
					}
				}
			}
		}
		return false;
	}
} team[35];

int main()
{
	int n, t, g, i, j, g1, g2;
	scanf("%d\n", &n);
	while (n--)
	{
		memset(team, 0, sizeof(team));
		gets(tournament);
		scanf("%d\n", &t);
		for (i = 0; i < t; ++i)
			gets(team[i].name);
		scanf("%d\n", &g);
		while (g--)
		{
			getline(cin, name1, '#');
			getline(cin, goals1, '@');
			getline(cin, goals2, '#');
			getline(cin, name2);
			for (i = 0; name1 != team[i].name; ++i)
				;
			for (j = 0; name2 != team[j].name; ++j)
				;
			g1 = atoi(goals1.c_str());
			g2 = atoi(goals2.c_str());
			++team[i].played, ++team[j].played;
			team[i].scored += g1, team[j].scored += g2;
			team[i].against += g2, team[j].against += g1;
			if (g1 == g2) ++team[i].tie, ++team[j].tie;
			else if (g1 > g2) ++team[i].win, ++team[j].loss;
			else ++team[i].loss, ++team[j].win;
		}
		for (i = 0; i < t; ++i)
		{
			team[i].point = 3 * team[i].win + team[i].tie;
			team[i].diff = team[i].scored - team[i].against;
		}
		sort(team, team + t);
		puts(tournament);
		for (i = 0; i < t; ++i)
			printf("%d) %s %dp, %dg (%d-%d-%d), %dgd (%d-%d)\n", i + 1, team[i].name, team[i].point, team[i].played, team[i].win, team[i].tie, team[i].loss, team[i].diff, team[i].scored, team[i].against);
		if (n) putchar(10);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值