UVa 10013 Super long sums (简单高精度)

21 篇文章 0 订阅

10013 - Super long sums

Time limit: 3.000 seconds 

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=954

The Problem

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

The Input

The first line of a input file is an integer N, then a blank line followed by N input blocks. The first line of an each input block contains a single number M (1<=M<=1000000) — the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next M lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed M.

There is a blank line between input blocks.

The Output

Each output block should contain exactly M digits in a single line representing the sum of these two integers.

There is a blank line between output blocks.

Sample Input

240 44 26 83 733 07 92 8

Sample Output

4750470

完整代码:

/*0.915s*/

#include<cstdio>

int a[1000010], b[1000010], c[1000010];

int main()
{
	int t, M, i, k, carry;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &M);
		for (i = 0; i < M; ++i)
			scanf("%d%d", &a[i], &b[i]);
		carry = 0;
		for (i = M - 1; i >= 0; --i)
		{
			k = carry + a[i] + b[i];
			carry = k > 9 ? 1 : 0;
			c[i] = k % 10;
		}
		for (i = 0; i < M; i++)
			printf("%d", c[i]);
		putchar(10);
		if(t) putchar(10);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值