北大ACM POJ 2602 Superlong sums

Superlong sums
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21539 Accepted: 6316

Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.

Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750

Hint

Huge input,scanf is recommended.

Source

 

 

#include <stdio.h>
char a[1000001];
int main(){
    int i,b,carry,n;
    scanf("%d\n",&n);
    for(i=0;i<n;i++){
        scanf("%d%d",&a[i],&b);
        a[i]+=b;
    }
    for(carry=0;i--;){
        a[i]+=carry;
        if(a[i]>9){
            carry=1;
            a[i]%=10;
        }
        else{
            carry=0;
        }
        a[i]+='0';
    }
    puts(a);
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值