UVa 10220 I Love Big Numbers ! (简单高精度)

21 篇文章 0 订阅

10220 - I Love Big Numbers !

Time limit: 3.000 seconds 

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1161

The Problem

A Japanese young girl went to a Science Fair at Tokyo. There she met with a Robot named Mico-12, which had AI (You must know about AI-Artificial Intelligence). The Japanese girl thought, she can do some fun with that Robot. She asked her, "Do you have any idea about maths ?"."Yes! I love mathematics", The Robot replied.

"Okey ! Then I am giving you a number, you have to find out the Factorial of that number. Then find the sum of the digits of your result!. Suppose the number is 5.You first calculate 5!=120, then find sum of the digits 1+2+0=3.Can you do it?"

"Yes. I can do!"Robot replied.

"Suppose the number is 100, what will be the result ?".At this point the Robot started thinking and calculating. After a few minutes the Robot head burned out and it cried out loudly "Time Limit Exceeds".

The girl laughed at the Robot and said "The sum is definitely 648".

"How can you tell that ?" Robot asked the girl. "Because I am an ACM World Finalist and I can solve the Big Number problems easily." Saying this, the girl closed her laptop computer and went away.

Now, your task is to help the Robot with the similar problem.

 

The Input

The input file will contain one or more test cases.

Each test case consists of one line containing an integers n (n<=1000).

The Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2^31-1.

Sample Input

5
60
100 

Sample Output

3
288
648

完整代码:

/*0.036s*/

#include<cstdio>
#include<cstring>

int num[3000];

int main()
{
	int i, j, s, c, n, sum, local;
	while (~scanf("%d", &n))
	{
		memset(num, 0, sizeof(num));
		num[0] = 1, local = 3;
		for (i = 2; i <= n; ++i)
		{
			c = 0;
			for (j = 0; j < local; ++j)
			{
				s = i * num[j] + c;
				c = s / 10;
				num[j] = s % 10;
			}
			local += 3;
		}
		sum = 0;
		for (i = 0; i < 3000; ++i)
			sum += num[i];
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值