唯一分解定理

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.
Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.
Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.
Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output
For each case, print the case number and the number of possible carpets.
Sample Input
2 10 2 12 2
Sample Output
Case 1: 1
Case 2: 2
题目大意:给出矩形面积ab,和组成该矩形的边的最小值,问这种面积为ab的矩形有几种。
这道题用到了唯一分解定理:N = p1a1*p2a2p3^a3pn^an(其中p1、p2、… pn为N的因子,a1、a2、… 、an分别为因子的指数)
N的因子个数 M = (1 + a1)
(1 + a2)(1 + a3)…*(1 + an);
用唯一分解定理求出ab的因子个数,但题要求的是满足条件的因子对数,所以最终所求的因子个数需要除以2,然后再将不满足的减去
该题要用到筛选素数来缩短时间。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1000000;
long long prime[N+100],vis[N+100],k;
void w()
{
    k=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1;
        for(int i=2;i<=N;i++)
        {
        if(!vis[i])
        {
            prime[k++]=i;
            for(int j=i*2;j<=N;j=j+i)
                vis[j]=1;
        }
        }
}
int main()
{
    w();
    int t,p=1;
    scanf("%d",&t);
    while(t--)
    {
        long long a,b,num=1,n,i;
        scanf("%lld%lld",&a,&b);
        n=a; 
        if(a<b*b)
        {
            printf("Case %d: 0\n",p++);
            continue;
        }
        for(i=0;i<k&&prime[i]*prime[i]<=n;i++)
        {
            if(n%prime[i]==0)
            {
                long long ans=0;
            while(n%prime[i]==0)
            {
                ans++;
                n/=prime[i];
            }
            num*=(ans+1);
            }
        }
        if(n<=1)
            num/=2;
            for(i=1;i<b;i++)
                if(a%i==0)
                num--;
        printf("Case %d: %lld\n",p++,num);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值