天梯赛—最小堆

7-11 关于堆的判断 (25 分)
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m;
int heap[20000],ans=0;
void push(int x)
{
    int i=ans++;
  //  printf("%d++\n",i);
    while(i>0)
    {
        int p=(i-1)/2;
        if(heap[p]<=x)
            break;
        heap[i]=heap[p];
        i=p;
    }
    heap[i]=x;
}
int find(int x)
{
    for(int i=0; i<n; i++)
    {
        if(heap[i]==x)
            return i;
    }
    return -1;
}
int main()
{
    int x1,x2,x;

    cin>>n>>m;
    for(int i=0; i<n; i++)
    {
        cin>>x;
        push(x);
    }
     string s;
    for(int i=0; i<m; i++)
    {
        cin>>x1;
        cin>>s;
        if(s=="and")
        {
            cin>>x2;
            cin>>s;
            cin>>s;
            if((find(x1)-1)/2==(find(x2)-1)/2)
                printf("T\n");
            else
                printf("F\n");
        }
        else
        {
            cin>>s;
            if(s=="a")
            {
                cin>>s;
                cin>>s;
                cin>>x2;
                if(find(x1)>=find(x2)*2+1&&find(x2)*2+2>=find(x1))
                    printf("T\n");
                else
                    printf("F\n");
            }
            else
            {
                cin>>s;
                if(s=="root")
                {
                    if(find(x1)==0)
                        printf("T\n");
                    else
                        printf("F\n");
                }
                else
                {
                   cin>>s;
                    cin>>x2;
                    if(find(x1)*2+2>=find(x2)&&find(x2)>=find(x1)*2+1)
                    printf("T\n");
                    else
                    printf("F\n");
                }
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值