简单括号匹配


Description

检查输入字符串中的括号是否匹配。括号包括:{, }, (, ), [, ].
 

Input

第一行是一整数,即测试样例个数n.
以下n行,每一行是一个长度不超过100个字符的字符串。
 

Output

匹配成功输出Yes,否则输出No,每个输出加换行。
 

Sample Input
4
a
2-[(1+2)*2]
(a+b])
([a+b)]
Sample Output
Yes
Yes
No
No

利用栈来储存:
// Problem#: 20264
// Submission#: 5007190
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
bool cmp(char h, char r) {
    if (h== ')'&& r== '(') return true;
    if (h== ']'&& r== '[') return true;
    if (h== '}'&& r== '{') return true;
    return false;
}
int main() {
    int n;
    stack<char> s;
    string str;
    cin>> n;
    while (n--) {
        bool flag= true;
        cin>> str;
        for (int i= 0; i< str.size(); i++) {
            if (str[i]== '('|| str[i]== '['|| str[i]== '{') {
                s.push(str[i]);
            }
            if (str[i]== ')'|| str[i]== ']'|| str[i]== '}') {
                if (!s.empty()) {
                    if (cmp(str[i], s.top())) {
                        s.pop();
                    } else {
                        flag= false;
                    }
                } else {
                    flag= false;
                }
            }
        }
        if (s.empty()&&flag) cout<< "Yes"<< endl;
        else cout<< "No"<< endl;
        while (!s.empty()) s.pop();
    }
}                                 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值