poj 2010 Moo University - Financial Aid——优先队列+贪心(详细注释)

7 篇文章 0 订阅
3 篇文章 0 订阅

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,“Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1…2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2…C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs

Output

  • Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.

详细解释

这是一道联系贪心和优先队列的好题

  1. 既要分数高,还要钱少,两个条件限制,就不得不掏出优先队列了。
  2. 我们对分数进行排序,然后分为lower和upper两个数组来辅助,lower表示的是前n/2再加上这个中位数所花的money,upper表示的是对后n/2和这个中位数所花的钱,他们都是当前状态的最小值。
    两次都算上了中位数,所以最后需要减去一次
#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
#include<set>
#include<stdlib.h>
#include<time.h>
using namespace std;
typedef long long ll;
#define inf	1000000
typedef pair<int,int>	P;
//存放cow的score和money
P a[100001];
//lower【i】表示的是从1到i中n/2个cow的money最小的,也就是中位数之前的
int lower[100001];
//upper【i】表示的是从c到i中n/2个cow的money最小的 ,也就是中位数之后的
int upper[100001];

int main() {
	int n,c,f;
	while(scanf("%d%d%d",&n,&c,&f)!=EOF) {
		for(int i=1; i<=c; i++) {
			cin>>a[i].first>>a[i].second;
		}
		//按照分数从小到大排序
		sort(a+1,a+1+c);
		//构造优先队列,对money从小到大排序,即队首是money最大的
		priority_queue<int>	myQ;
		//sum用来保存前n/2个数字的和的最小
		int sum=0;
		// 对中位数前面的money进行计算
		for(int i=1; i<=c; i++) {
			sum+=a[i].second;
			myQ.push(a[i].second);
			//先保证至少有n/2存在,然后之后的话,每次pop最大的,计算lower值
			if(i>n/2) {
				//把中位数也算上,最后再减去
				lower[i]=sum;
				sum-=myQ.top();
				myQ.pop();

			}
		}
		//队列清空
		while(!myQ.empty()) {
			myQ.pop();
		}
		//sum清零
		sum=0;
		//对中位数后面的money进行计算
		for(int i=c; i>0; i--) {
			sum+=a[i].second;
			myQ.push(a[i].second);
			//先保证至少后一半求出来,然后对每个数进行重新判定
			if(i<=c-n/2) {
				//先赋值upper,然后再对这个数字进行判定,因为
				//这个数字是假设他就是中位数,所以不能把他加上
				upper[i]=sum;
				sum-=myQ.top();
				myQ.pop();

			}
		}
		//求解最大的中位数,直接从后往前开始,一旦满足就退出
		int i;
		for(i=c-n/2; i>n/2; i--) {
			if(lower[i]+upper[i]-a[i].second<=f) {
				cout<<a[i].first<<endl;
				break;
			}
		}
		//如果都没有满足条件的话,就输出-1
		if(i==n/2) {
			cout<<-1<<endl;
		}
	}
	return 0;
}

提醒你大家一点,lower和upper数组别开成n大小了(我就在这卡了半天),因为我们计算的是所有的数的情况!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值