Find them, Catch them poj1703

问题描述

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

输入

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

输出

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

样例输入

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

样例输出

Not sure yet.
In different gangs.
In the same gang.

/*用并查集来做这个题,mark[i]表示i与父节点是否是同一个gang,如果是则为1,否则为0;
代码如下:
*/

#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;

const int maxx=100000+20;
int pre[maxx];int mark[maxx];

int find(int x)//找根;
{
    if(pre[x]==x)
        return x;
    
    int tem=pre[x];
    pre[x]=find(pre[x]);
    mark[x]=(mark[x]+mark[tem]+1)%2;//将性质延续
    
    return pre[x];
}

void Union(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
    {
        pre[xx]=yy;
        mark[xx]=(mark[x]+mark[y])%2;//将性质取反
    }

}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {


        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            pre[i]=i;mark[i]=1;
        }


        char ch;int aa,bb;
        while(m--)
        {
            scanf(" %c%d%d",&ch,&aa,&bb);

            if(ch=='A')
            {

                int fa=find(aa);
                int fb=find(bb);
                if(fa!=fb)
                    printf("Not sure yet.\n");
                else if(mark[aa]==mark[bb])//=0时说明和祖先不是一个gang,即他俩是一个gang,=1说明他们在同一个祖先中,也是在一个gang
                    printf("In the same gang.\n");
                else
                    printf("In different gangs.\n");
            }
            else
            {
                Union(aa,bb);
            }
        }

    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值