C UVA 12293 Box Game

There are two identical boxes. One of them contains n balls, while the other box contains one ball. Alice and Bob invented a game with the boxes and balls, which is played as follows:
Alice and Bob moves alternatively, Alice moves first.
For each move, the player finds out the box having fewer number of balls inside, and empties that box (the balls inside will be removed forever), and redistribute the balls in the other box. After the redistribution, each box should contain at least one ball. If a player cannot perform a valid move, he loses.
A typical game is shown below:
When both boxes contain only one ball, Bob cannot do anything more, so Alice wins.
Question: if Alice and Bob are both clever enough, who will win? Suppose both of them are very smart and always follows a perfect strategy.
Input There will be at most 300 test cases. Each test case contains an integer n (2 ≤ n ≤ 109) in a single line. The input terminates by n = 0.
Output
For each test case, print a single line, the name of the winner.
Sample Input
2
3
4
0
Sample Output
Alice
Bob
Alice

题意:有两个箱子,一个里面有n个球,另一个有1个球。然后A(alice)和B(Bob)做游戏。游戏规则是: 两者轮流操作,A先开始:先将 球比较少 的箱子倒空,再将另一个箱子里的球分配到空箱子里,直到两个箱子都只有一个球。最终不能操作的人,输掉比赛。

思路:找规律 ,见下表;(n*2)+1
n值    赢的人

N值
赢的人
2A21A
3B22A
4A23A
5A24A
6A25A
7B26A
8A27A
9A28A
10A29A
11A30A
12A31B
13A32A
14A

15B

16A

17A

18A

19A

20A


 代码如下:
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
char mm[1000000005];
int main()
{
    long long ans=7;
    mem(mm,'A');
    mm[3]=mm[7]='B';
    for(int i=1;i<=25;i++)
    {
       ans=(ans*2)+1;
      // printf("%lld\n",ans);
       mm[ans]='B';
    }
    int n;
    while(~scanf("%d",&n)&&n)
    {
        if(mm[n]=='B')
            printf("Bob\n");
        else
            printf("Alice\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值