A - Kill the monster

A - Kill the monster  

There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).

Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.



Sample Input
3 100
10 20
45 89
5  40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40
Sample Output
3
2
-1
           
题意:一个勇敢的孩子带着 n 个技能,上山打怪兽。   这n个技能,有着普攻和暴击两种伤害。当怪兽的血量小于某个技能的Mi时,这个孩子可使用暴击,伤害翻倍。

思路:深搜每种情况,找到最优解。

代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int book[15];
struct xie
{
    int A,M;
}X[15];
int step,n,m;
void dfs(int s,int st)
{
    if(s<=0)                //剪枝
    {
        if(step>st)
            step=st;
         return;
    }
    for(int i=1;i<=n;i++)
    {
        if(book[i]==0)
        {
            book[i]=1;
             if(s<=X[i].M)
                dfs(s-2*X[i].A,st+1);           //怪兽血量少于M,减少普攻的两倍血。
            else
                dfs(s-X[i].A,st+1);            
            book[i]=0;                       //不要忘了。
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&X[i].A,&X[i].M);
        step=11;                            //n的范围(2-10),step要大于10;
        dfs(m,0);
        if(step==11)
            printf("-1\n");
        else
            printf("%d\n",step);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值