hdu1616 深搜+简单回溯

<span style="font-family: Arial, Helvetica, sans-serif; font-size: 18pt; background-color: rgb(255, 255, 255);">Description</span>

There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect. 
 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has. 
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m). 
 

Output

For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 

Sample Input

 
    
3 100 10 20 45 89 5 40 3 100 10 20 45 90 5 40 3 100 10 20 45 84 5 40
 

Sample Output

 
    
3 2 -1

题意:要杀死一只怪兽,每只符文可对怪兽造成A点伤害,若怪兽血量满足条件:HP<m[i],则可产生双倍暴击,问最少能用多少只符文可把怪兽杀死

解题思路:从第0次开始深搜,若遇到怪兽血量<=0,则记录下最小搜索深度,若搜索深度==n,则表示符文已用完,return。


#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;

int n,M;
int map[20];
struct node{
	int hp,m;
}spell[20];
int MIN=10000000;

void dfs(int x){
	if(M<=0){
		MIN=x<MIN?x:MIN;
		return;
	}
	if(x==n){//若第n次时被杀死,则n已经被记录下来 
		return;
	}
	else{
	    for(int i=0;i<n;i++){
	    	if(!map[i]){
	    		map[i]=1;
	    		int j=spell[i].hp;
	    		if(M<=spell[i].m)
	    		   j+=spell[i].hp;
	    		M-=j;
	    		dfs(x+1);
	    		map[i]=0;
	    		M+=j;
			}
		}
	}
	
}

int main(){
	freopen("input.txt","r",stdin);
	while(cin>>n>>M){
		memset(map,0,sizeof(map));
		MIN=10000000;
		for(int i=0;i<n;i++)
		    scanf("%d%d",&spell[i].hp,&spell[i].m);    
		dfs(0);
		if(MIN>=n+1)
		   printf("-1\n");
		else
		   printf("%d\n",MIN);
	}
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值