poj2425(博弈SG函数)

地址:http://poj.org/problem?id=2425

A Chess Game
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 2834 Accepted: 1170

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN


题意:先输入一个数字N,代表有N个方格。然后有N行,对于第i行,第一个数字M代表方格i能达到几个方格,然后M个数字分别是方格的编号。

            在后面是问题,每行第一个数字S表示棋子的数目,后面S个数表示棋子的所在方格的编号。

            输出win表示先手胜利,胜利条件是你走一步棋后,对方无棋可走。

代码:

#include<cstdio>
#include<vector>
#include<queue>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int map[1010][1010],sg[1010];
queue<int> qi;
void init()  //因为是3秒,所以处理暴力了点
{
	int t,m,k;
	vector<int> fsg;
	while(!qi.empty())
	{
		t=qi.front();qi.pop();k=0;
		for(int i=1;i<=map[t][0];i++)
		{
			if(sg[map[t][i]]!=-1)
			{
				fsg.push_back(sg[map[t][i]]);
			}
			else
			{
				qi.push(t);
				k=1;
				fsg.clear();
				break;
			}
		}
		if(k) continue;
		sort(fsg.begin(),fsg.end());
		if(fsg.size()==1)
		{
			if(fsg[0]) sg[t]=0;
			else sg[t]=1;
			fsg.clear();
			continue;
		}
		for(vector<int>::size_type j=1;j<fsg.size();j++)
		{
			if(fsg[0])
			{
				sg[t]=0;
				break;
			}
			if(fsg[j]-fsg[j-1]>1)
			{
				sg[t]=fsg[j-1]+1;
				break;
			}
			if(j==fsg.size()-1)
				sg[t]=fsg[j]+1;
		}
		fsg.clear();
	}
}
int main()
{
	int n,m,j;
	while(scanf("%d",&m)>0)
	{
		memset(map,0,sizeof(map));
		for(int i=0;i<m;i++)
		{
			scanf("%d",&n);
			map[i][0]=n;
			if(n==0)
			{
				sg[i]=0;
				continue;
			}
			for(j=1;j<=n;j++)
				scanf("%d",&map[i][j]);
			qi.push(i);
			sg[i]=-1;
		}
		init();
		while(scanf("%d",&n)>0,n)
		{
			int sum;
			for(int i=0;i<n;i++)
			{
				scanf("%d",&j);
				if(i==0) sum=sg[j];
				else sum^=sg[j];
			}
			if(sum) puts("WIN");
			else puts("LOSE");
		}
	}
}

网上找到了简单的代码,在这里也贴上:

#include<iostream>
#include<stack>
using namespace std;

int map[1010][1010];
int SG[1010];
int N;

//这是网上一个很好看的求SG值的办法
int DFS(int n) /* 典型求 SG 函数的办法 */
{
	int i;
    if(SG[n]!=-1) return SG[n];
    bool used[1010];
    memset(used,0,sizeof(used));
	for(i=0;i<N;i++)
    {
		if(map[n][i] != -1)
        used[DFS(i)]=true; //这里是DFS(i),表示i的SG值
    }
    i=0;
    while(used[i]) i++; //在这里算出n的SG值
    return SG[n]=i;
}


int main()
{
	int i,j,k,t;
	int X;
	int temp,ans;
	while(scanf("%d",&N) != EOF)
	{
		memset(map,255,sizeof(map));
		memset(SG,255,sizeof(SG));
		for(i=0;i<N;i++)
		{
			scanf("%d",&k);
			if(k == 0)
			{
				SG[i] = 0;
			}
			for(j=0;j<k;j++)
			{
				scanf("%d",&t);
				map[i][t] = 1;
			}
		}
		
		while(scanf("%d",&X) != EOF)
		{
			if(X == 0) break;
			ans = 0;
			for(i=0;i<X;i++)
			{
				scanf("%d",&temp);
				ans = ans ^DFS(temp);
			}
			if(ans != 0)
			{
				printf("WIN\n");
			}
			else
			{
				printf("LOSE\n");
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值