uva 11137 Ingenuous Cubrency

原题:
People in Cubeland use cubic coins. Not only the unit of currency is called a cube but also the coins are shaped like cubes and their values are cubes. Coins with values of all cubic numbers up to 9261(= 213),i.e., coins with the denominations of 1, 8, 27, …, up to 9261 cubes,are available in Cubeland.Your task is to count the number of ways to pay a given amount using cubic coins of Cubeland. For example, there are 3 ways to pay 21 cubes: twenty one 1 cube coins, or one 8 cube coin and thirteen 1 cube coins, or two 8 cube coin and five 1 cube coins.
Input
Input consists of lines each containing an integer amount to be paid. You may assume that all the
amounts are positive and less than 10000.
Output
For each of the given amounts to be paid output one line containing a single integer representing the
number of ways to pay the given amount using the coins available in Cubeland.
Sample Input
10
21
77
9999
Sample Output
2
3
22
440022018293
大意:
给你一堆面额是i^3的钞票,问你组成一个数n有多少种可能。

#include <bits/stdc++.h>

using namespace std;
long long dp[10001];
int coin[22];
int main()
{
    ios::sync_with_stdio(false);
    for(int i=1;i<=21;i++)
        coin[i]=i*i*i;
        dp[0]=1;
    for(int i=1;i<=21;i++)
    {
        for(int j=coin[i];j<=10000;j++)
            dp[j]+=dp[j-coin[i]];
    }
    int n;
    while(cin>>n)
        cout<<dp[n]<<endl;
    return 0;
}






解答:
完全背包的经典换钱问题,dp[j]表示面额为j的钱币有多少种换法,则dp[j-coin[i]]表示使用硬币coin[i]有多少种换法,累加即可。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值