uva 10167 Birthday Cake

原题:
Lucy and Lily are twins.Today is their birthday.Mother buys a birthday cake for them. Now we put
the cake onto a Descartes coordinate. Its center is at (0,0), and the cake’s length of radius is 100.
There are 2N (N is a integer, 1 ≤ N ≤ 50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?
Note: the coordinate of a cherry (x,y) are two integers. You must give the line as form two integers A,B (stands for Ax + By = 0) each number mustn’t in [−500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.
这里写图片描述
Input
The input file contains several scenarios. Each of them consists of 2 parts:
The first part consists of a line with a number N, the second part consists of 2N lines, each line
has two number, meaning (x,y). There is only one space between two border numbers. The input file
is ended with N = 0.
Output
For each scenario, print a line containing two numbers A and B. There should be a space between
them. If there are many solutions, you can only print one of them.
Sample Input
2
-20 20
-30 20
-10 -50
10 -5
0
Sample Output
0 1
大意:
给你一个直径是100的蛋糕,上面有2*n个草莓。现在让你找出A和B使得沿着直线AX+BY=0切割能使得两半的蛋糕上面有数目相同的草莓。(不会有两个草莓在一条直线上)

#include <bits/stdc++.h>

using namespace std;
//fstream in,out;
struct point
{
    int x,y;
};
point p[101];
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n,n)
    {
        for(int i=1;i<=n*2;i++)
            cin>>p[i].x>>p[i].y;
        int flag=0,mark=0;
        int cnt=0,a,b;
        for(int A=-500;A<=500;++A)
        {
            for(int B=-500;B<=500;++B)
            {
                mark=cnt=0;
                int i;
                if(A==0&&B==0)
                    continue;
                for(i=1;i<=n*2;i++)
                {
                    if(A*p[i].x+B*p[i].y==0)
                    {
                        mark=1;
                        break;
                    }
                    if(A*p[i].x+B*p[i].y<0)
                        cnt++;
                }
                if(cnt==n&&mark==0)
                {
                    a=A;
                    b=B;
                    flag=1;
                    break;
                }
            }
            if(flag)
                break;
        }
        cout<<a<<" "<<b<<endl;
    }
    return 0;
}

解答:
感觉自己代码能力比较粗糙,就找了点暴力求解的问题去做。这题刚拿到的时候没仔细看数据,大概明白了什么意思就开始做,结果想了好久也没想出来。后来看别人的报告,发现A和B的范围是[-500,500]而且不用考虑小数的问题。 那么这道题就相当简单了,直接枚举每个A和B就行了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值