uva 10635 Prince and Princess

原题:
In an n×n chessboard, Prince and Princess plays a game. The squares in the chessboard are numbered
1,2,3,…,n ∗ n, as shown below:
这里写图片描述
Prince stands in square 1, make p jumps and finally reach square n∗n. He enters a square at most
once. So if we use xpto denote the p-th square he enters, then x1, x2, …, xp+1are all different. Note
that x1= 1 and xp+1= n ∗ n. Princess does the similar thing – stands in square 1, make q jumps and
finally reach square n ∗ n. We use y1, y2, …, yq+1to denote the sequence, and all q + 1 numbers are
different.
Figure 2 belows show a 3×3 square, a possible route for Prince and a different route for Princess.
这里写图片描述
The Prince moves along the sequence: 1 –> 7 –> 5 –> 4 –> 8 –> 3 –> 9 (Black arrows), while the
Princess moves along this sequence: 1 –> 4 –> 3 –> 5 > 6 –> 2 –> 8 –> 9 (White arrow).
The King – their father, has just come. “Why move separately? You are brother and sister!” said
the King, “Ignore some jumps and make sure that you’re always together.”
For example, if the Prince ignores his 2nd, 3rd, 6th jump, he’ll follow the route: 1 –> 4 –> 8 –>
9. If the Princess ignores her 3rd, 4th, 5th, 6th jump, she’ll follow the same route: 1 –> 4 –> 8 –>
9, (The common route is shown in figure 3) thus satisfies the King, shown above. The King wants to
know the longest route they can move together, could you tell him?
Input
The first line of the input contains a single integer t (1 ≤ t ≤ 10), the number of test cases followed.
For each case, the first line contains three integers n, p, q (2 ≤ n ≤ 250, 1 ≤ p,q < n ∗ n). The second
line contains p+1 different integers in the range [1…n∗n], the sequence of the Prince. The third line
contains q + 1 different integers in the range [1…n ∗ n], the sequence of the Princess.
Output
For each test case, print the case number and the length of longest route. Look at the output for sample
input for details.
Sample Input
1
3 6 7
1 7 5 4 8 3 9
1 4 3 5 6 2 8 9
Sample Output
Case 1: 4
大意:
给你两个数字序列,每个数字序列当中不存在重复的数字。问你这两个数字序列的最长公共子序列是多少?

#include <bits/stdc++.h>
using namespace std;
int dp[62501];
int ce[62501],ess[62501],mark[62501];
int main()
{
    ios::sync_with_stdio(false);
    int t,k=1,n,p,q,ans;
    cin>>t;
    while(t--)
    {
        cin>>n>>p>>q;
        ans=0;
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=p+1;i++)
        {
            cin>>ce[i];
            mark[ce[i]]=i;
        }
        for(int i=1;i<=q+1;i++)
        {
            cin>>n;
            ess[i]=mark[n];
            dp[i]=INT_MAX;
        }
        for(int i=1;i<=q+1;i++)
        {
            int index=lower_bound(dp+1,dp+1+i,ess[i])-dp;
            dp[index]=ess[i];
            ans=max(ans,index);
        }
        cout<<"Case "<<k++<<": "<<ans<<endl;
    }
    return 0;
}

解答:
上来就用lcs,明知道时间复杂度肯定会挂,但我还是试了一试,果然超时=_=
在那个lucky猫上面的标签上面看到这道题的标签lis,也就是最长递增子序列。当时很纳闷,这题怎么用最长递增子序列解啊?简单想了一会,百度最长公共子序列 o(nlogn)结果居然真的有,而且翻了翻lrj的训练指南,发现书上也有这道题的例题。仔细端详过后感觉想出这方法的人真是好聪明啊!
最长公共子序列o(nlogn)算法
操作步骤,先设两个序列分别为a和b,数字个数分别为la,lb。然后把a中的数字重新按照1到la排序。
比如样例当中a={1,7,5,4,8,3,9}重新编排后变成{1,2,3,4,5,6,7}。然后对应到b当中,如果没有的就用0代替
b变成{1,4,6,3,0,0,5,7},然后求b的最长递增子序列就行了,别脑袋发热又写了个o(n^2)的算法要用二分的那个。
想了一会为啥这样做就能算是找到最长公共子序列了呢?我的理解,应该是把a中的序列重新编排后再映射到b中,这个映射的过程就相当于在是b中标记处了a当中的元素,重排之后的a是递增的,所以找b当中的最长递增序列就相当于找到了本序列和a序列当中最多重合的元素。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值