uva 11572 Unique Snowflakes

原题:
Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a
machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow,
one by one, into a package. Once the package is full, it is closed and shipped to be sold.
The marketing motto for the company is “bags of uniqueness.” To live up to the motto, every
snowflake in a package must be different from the others. Unfortunately, this is easier said than done,
because in reality, many of the snowflakes flowing through the machine are identical. Emily would like
to know the size of the largest possible package of unique snowflakes that can be created. The machine
can start filling the package at any time, but once it starts, all snowflakes flowing from the machine
must go into the package until the package is completed and sealed. The package can be completed
and sealed before all of the snowflakes have flowed out of the machine.
Input
The first line of input contains one integer specifying the number of test cases to follow. Each test
case begins with a line containing an integer n, the number of snowflakes processed by the machine.
The following n lines each contain an integer (in the range 0 to 10 9 , inclusive) uniquely identifying a
snowflake. Two snowflakes are identified by the same integer if and only if they are identical.
The input will contain no more than one million total snowflakes.
Output
For each test case output a line containing single integer, the maximum number of unique snowflakes
that can be in a package.
Sample Input
1
5
1
2
3
2
1
Sample Output
3
题目大意:
给你n个数,问你最长的连续的不出现重复的数的长度是多少?

#include <bits/stdc++.h>

using namespace std;
int a[1000001];
fstream in,out;
map<int,int> mi;
int main()
{
    ios::sync_with_stdio(false);
    int t,n,ans;
//  in.open("in.txt");
//  out.open("answer.txt");
    cin>>t;
    while(t--)
    {
        cin>>n;
        ans=1;
        mi.clear();
        for(int i=1;i<=n;i++)
            cin>>a[i];
        int l=1;
        mi[a[1]]=1;
        for(int i=2;i<=n;i++)
        {
            int mark=mi[a[i]];
            if(mark>=l)
                l=mark+1;
            ans=max(ans,i-l+1);
            mi[a[i]]=i;
        }
        cout<<ans<<endl;
    }
//  in.close();
//  out.close();
    return 0;
}

解答:
在书上随便翻到的一个例题,在leetcode里面做过类似的。用一个map记录每个数字出现过的位置,设置l和r分别表示这个最长连续不重复数组的两端,其中r可以用遍历中的i代替。如果遍历到map查找遍历到的a[i]在前面出现的位置,如果在正在遍历的数组当中就把l设置成上一次出现a[i]的位置并加一,不断更新最大值即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值