uva 10125 Sumsets

原题:
Given S, a set of integers, find the largest d such that a + b + c = d
where a, b, c, and d are distinct elements of S.
Input
Several S, each consisting of a line containing an integer 1 ≤ n ≤
1000 indicating the number of elements in S, followed by the elements
of S, one per line. Each element of S is a distinct integer between -
536870912 and +536870911 inclusive. The last line of input contains
‘0’.
Output
For each S, a single line containing d, or a single line containing ‘no solution’.
Sample Input
5
2
3
5
7
12
5
2
16
64
256
1024
0
Sample Output
12
no solution
中文:
给你一堆不重复的数,现在让你找出这样一个最大的数d,满足条件a+b+c=d,其中a,b,c,d各不相同。 数的个数不超过1000个

使用set

#include <bits/stdc++.h>
using namespace std;
//fstream in,out;
struct node
{
    int num;
    int res;
    node(int n,int r){ num = n, res = r;}
    bool operator<(const node& n) const
    {
        return res<n.res;
    }
};
vector<node> sum;
vector<int> vi;
int main()
{
    ios::sync_with_stdio(false);
    int n;
//    in.open("in.txt");
//    out.open("out.txt");
    while(cin>>n,n)
    {
        sum.clear();
        vi.clear();
        for(int i=0;i<n;i++)
        {
            int res;
            cin>>res;
            vi.push_back(res);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                int s=vi[i]+vi[j];
                sum.push_back(node(vi[i],s));
            }
        }
        set<node> sn(sum.begin(),sum.end());
        sort(vi.begin(),vi.end());
        int flag=1;
        for(int i=vi.size()-1;i>=0;i--)
        {
            for(int j=0;j<vi.size();j++)
            {
                if(i==j)
                continue;
                int sub=vi[i]-vi[j];
                auto sit=sn.find(node(0,sub));
                if(sit==sn.end())
                continue;
                int a=sit->num;
                int b=sit->res-a;
                int c=vi[j];
                int d=vi[i];
                if(a!=c&&a!=d&&b!=c&&b!=d)
                {
                    cout<<d<<endl;
                    flag=0;
                    break;
                }
            }
            if(!flag)
            break;
        }
        if(flag)
            cout<<"no solution"<<endl;
    }
//    in.close();
//    out.close();
    return 0;
}

使用哈希

#include <bits/stdc++.h>
using namespace std;
//fstream in,out;
typedef unordered_set<int> usi;

struct node
{
    int num;
    int res;
    node(int n,int r){ num = n, res = r;}
    bool operator==(const node& n) const//重载==运算符
    {
        return res==n.res;
    }
};
struct myhash
{
    size_t operator()(const node &n) const
    {
        usi::hasher fn= usi().hash_function();
        return fn(n.res);
    }
};
vector<node> sum;
vector<int> vi;
int main()
{
    ios::sync_with_stdio(false);
    int n;
//    in.open("in.txt");
//    out.open("out.txt");
    while(cin>>n,n)
    {
        sum.clear();
        vi.clear();
        for(int i=0;i<n;i++)
        {
            int res;
            cin>>res;
            vi.push_back(res);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                int s=vi[i]+vi[j];
                sum.push_back(node(vi[i],s));
            }
        }
        unordered_set<node,myhash> sn(sum.begin(),sum.end());
        sort(vi.begin(),vi.end());
        int flag=1;
        for(int i=vi.size()-1;i>=0;i--)
        {
            for(int j=0;j<vi.size();j++)
            {
                if(i==j)
                continue;
                int sub=vi[i]-vi[j];
                auto sit=sn.find(node(0,sub));
                if(sit==sn.end())
                continue;
                int a=sit->num;
                int b=sit->res-a;
                int c=vi[j];
                int d=vi[i];
                if(a!=c&&a!=d&&b!=c&&b!=d)
                {
                    cout<<d<<endl;
                    flag=0;
                    break;
                }
            }
            if(!flag)
            break;
        }
        if(flag)
            cout<<"no solution"<<endl;
    }
//    in.close();
//    out.close();
    return 0;
}

解答:

poj上面有一道类似的题目,给你四个数组,让你分别在这个四个数组里面选数,是的这四个数加起来和为0。
与上面这道题类似,a+b+c=d可以转换成a+b=d-c,枚举a+b的值,存在一个哈希表或者是查找树里面,然后枚举d-c的值,在哈希表或者查找树中查找即可。注意要判断abcd四个数是否有重复的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值