uva 439 Knight Moves

原题:
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the
shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the
”difficult” part.Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two
squares separated by one space. A square is a string consisting of a letter (a..h) representing the column
and a digit (1..8) representing the row on the chessboard.
Output
For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

中文:
经典的骑士巡游问题,题目就不介绍了,没做过算是遗憾。

#include <bits/stdc++.h>
using namespace std;
struct point
{
    int x,y,pace;
};
bool vis[15][15];
string s1,s2;
int Move[8][2]={{1,2},{1,-2},{-1,2},{-1,-2},{2,1},{2,-1},{-2,1},{-2,-1}};
bool judge(point tmp)
{
    if(tmp.x>=1&&tmp.x<=8&&tmp.y>=1&&tmp.y<=8)
        return true;
    return false;
}
int bfs(point start,point End)
{
    queue<point> Q;
    memset(vis,false,sizeof(vis));
    Q.push(start);
    while(!Q.empty())
    {
        point tmp=Q.front();
        Q.pop();
        for(int i=0;i<8;i++)
        {
            int x=tmp.x+Move[i][0],y=tmp.y+Move[i][1],z=tmp.pace+1;
            point res;
            res.x=x,res.y=y,res.pace=z;
            if(judge(res))
            {
                if(x==End.x&&y==End.y)
                    return res.pace;
                if(!vis[x][y]&&judge(res));
                {
                    vis[x][y]=1;
                    Q.push(res);
                }
            }
        }
    }
    return -1;
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>s1>>s2)
    {
        if(s1==s2)
        {
            cout<<"To get from "<<s1<<" to "<<s2<<" takes "<<0<<" knight moves."<<endl;
            continue;
        }
        point s,e;
        s.x=s1[0]-'a'+1;
        s.y=s1[1]-'0';
        s.pace=0;
        e.x=s2[0]-'a'+1;
        e.y=s2[1]-'0';
        e.pace=0;
        vis[s.x][s.y]=1;

        int ans=bfs(s,e);
        cout<<"To get from "<<s1<<" to "<<s2<<" takes "<<ans<<" knight moves."<<endl;
    }
    return 0;
}

解答:
非常经典的一道题目,我记得这是我做的第一道搜索的题目,当时抱着ppt看了半天。现在信手拈来,没再自己的博客里面记录一下是个遗憾啊!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值