[ACM] hdu 1671 Phone List (字典树)

286 篇文章 140 订阅
5 篇文章 0 订阅

Phone List



Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source



解题思路:

判断输入的串中是否存在某个串是另外串的前缀。
建立字典树,关键是设立某个串结尾的标志,即在哪个字母结尾。要判断是否存在前缀要考虑两种情况,一是当前输入的串是否是以前输入的串的前缀,而是以前输入的串是否是当前输入的串的前缀。前一种情况在查找该串时,会从第一个字母查找到最后一个字母,中间不返回任何值,说明当前的串是以前的前缀,后一种情况,当在查找当前串的时候遇到以前串结束的标志,则说明以前串是当前串的前缀。代码中结束的标志为保存串中最后一个字母的那个节点的cnt值为-1.

如图:


代码:

#include <iostream>
#include <malloc.h>
#include <algorithm>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn=10;
bool ok;
char str[12];
int t,n;

struct Trie
{
    int cnt;
    Trie *next[maxn];
};

Trie *root;

void CreateTrie(char *str)
{
    int len=strlen(str);
    Trie*p=root,*q;
    for(int i=0;i<len;i++)
    {
        int id = str[i]-'0';
        if(p->next[id] == NULL)
        {
            q = (Trie *)malloc(sizeof(Trie));
            q->cnt = 1;
            for(int j=0; j<maxn; ++j)
                q->next[j] = NULL;
            p->next[id] = q;
            p = p->next[id];
        }
        else
        {
            p = p->next[id];
        }
    }
    p->cnt=-1;//串末尾的标志
}

int findTrie(char *str)
{
    int len=strlen(str);
    Trie *p=root;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if(p->next[id]==NULL)
            return 0;//没有建过树
        if(p->next[id]->cnt==-1)
            return -1;//以前串是当前串的前缀
        p=p->next[id];
    }
    return -1;//当前串是以前串的前缀
}

void release(Trie *root)//释放空间
{
    for(int i=0;i<maxn;i++)
    {
        if(root->next[i])
            release(root->next[i]);
    }
    free(root);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        ok=1;
        root=(Trie*)malloc(sizeof(Trie));//root为指针类型,需要申请空间
        for(int i=0; i<10; ++i)
            root->next[i] = NULL;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s",str);
            if(findTrie(str)==-1)
                ok=0;//有前缀
            if(!ok)
                continue;//有前缀,后面的就不用建树了
            CreateTrie(str);
        }
        if(ok)
            printf("YES\n");
        else
            printf("NO\n");
        release(root);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值