微软实习机试题 String reorder 的 Java 实现

【Description】

Your program should reorder and split all input string characters into multiple segments, and output all segments as one concatenated string. The following requirements should also be met,

1. Characters in each segment should be in strictly increasing order. For ordering, ‘9’ is larger than ‘0’, ‘a’ is larger than ‘9’, and ‘z’ is larger than ‘a’ (basically following ASCII character order).
2. Characters in the second segment must be the same as or a subset of the first segment; and every following segment must be the same as or a subset of its previous segment.
Your program should output string “<invalid input string>” when the input contains any invalid characters (i.e., outside the '0'-'9' and 'a'-'z' range).
【Input】
Input consists of multiple cases, one case per line. Each case is one string consisting of ASCII characters.
【Output】
For each case, print exactly one line with the reordered string based on the criteria above.

【样例输入】

aabbccdd
007799aabbccddeeff113355zz
1234.89898
abcdefabcdefabcdefaaaaaaaaaaaaaabbbbbbbddddddee

【样例输出】

abcdabcd
013579abcdefz013579abcdefz
<invalid input string>
abcdefabcdefabcdefabdeabdeabdabdabdabdabaaaaaaa

【AC代码】

import java.util.ArrayList;
import java.util.Arrays;
import java.util.HashSet;
import java.util.List;
import java.util.Scanner;
import java.util.Set;

public class Main {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		String str, re;
		while (in.hasNextLine()) {
			str = in.nextLine();
			re = process(str);
			System.out.println(re);
		}

	}

	private static String process(String str) {
		char[] chs = str.toCharArray();
		for (char c : chs) {
			if (!(Character.isDigit(c) || Character.isLowerCase(c))) {
				return "<invalid input string>";
			}
		}
		List<Character> li = new ArrayList<Character>();
		for (char c : chs) {
			li.add(c);
		}
		String re = "";
		Set<Character> se = new HashSet<Character>();
		while (li.size() > 0) {
			for (int i = li.size() - 1; i >= 0; i--) {
				if (se.add(li.get(i))) {
					li.remove(i);
				}
			}
			String re2="";
			for (Character ttt : se) {
				re2 += ttt;
			}
			char[] ttt = re2.toCharArray();
			Arrays.sort(ttt);
			String tss = new String(ttt);
			se.clear();
			re += tss;
		}
		return re;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值