poj3406 Ant Counting

Ant Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6012 Accepted: 2240

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS: 

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


OUTPUT DETAILS: 

5 sets of ants with two members; 5 more sets of ants with three members

Source





根据题意可以推出dp[i+1][j]=dp[i+1][j-1]+dp[i][j]-dp[i][j-1-num[i]],注意最后要留6位数字,对1000000取模即可。




#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ma(a) memset((a),0,sizeof((a)))
const int MOD=1000000;
long long  int  dp[1005][100005];
long long  int  num[1005];
int main(){
	long long int t,a,s,b;
	while(scanf("%I64d%I64d%I64d%I64d",&t,&a,&s,&b)!=EOF)
	{
		//ma(dp);
		ma(num);
		int i,j,k;
		for(i=1;i<=a;i++)
		{
			cin>>j;
			num[j-1]++;
		}
		for(i=0;i<=t;i++)
		dp[i][0]=1;
		for(i=0;i<t;i++)
		{
			for(j=1;j<=b;j++)
			{
				if(j-1-num[i]>=0)
				dp[i+1][j]=(dp[i+1][j-1]+dp[i][j]-dp[i][j-1-num[i]]+MOD)%MOD;
				else 
				dp[i+1][j]=(dp[i+1][j-1]+dp[i][j])%MOD;
			}
		}
		long long int ans=0;
		for(i=s;i<=b;i++)
		{
			ans=(ans+dp[t][i])%MOD;
		}
	     printf("%I64d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值