Hdu 1081 长方形列举To The Max

Hdu 1081 长方形列举To The Max

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7349    Accepted Submission(s): 3554

 

 

Problem Description

Given a two-dimensional array of positiveand negative integers, a sub-rectangle is any contiguous sub-array of size 1 x1 or greater located within the whole array. The sum of a rectangle is the sumof all the elements in that rectangle. In this problem the sub-rectangle withthe largest sum is referred to as the maximal sub-rectangle.

 

As an example, the maximal sub-rectangle ofthe array:

 

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

 

is in the lower left corner:

 

9 2

-4 1

-1 8

 

and has a sum of 15.

 

 

Input

The input consists of an N x N array ofintegers. The input begins with a single positive integer N on a line byitself, indicating the size of the square two-dimensional array. This isfollowed by N 2 integers separated by whitespace (spaces and newlines). Theseare the N 2 integers of the array, presented in row-major order. That is, allnumbers in the first row, left to right, then all numbers in the second row,left to right, etc. N may be as large as 100. The numbers in the array will bein the range [-127,127].

 

 

Output

Output the sum of the maximalsub-rectangle.

 

 

Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

 

 

Sample Output

15

 

 

Source

Greater New York 2001

 

题解:

长方形列举,sum[i][j]记录从a[i][1]到a[i][j]的和,所以在下面列举长方形时,一开始是从sum[1][1]列举起,宽度一定,先是长度的增加,如果面积小于0,则没有必要加到下面的面积了,重新计算宽度为一的长方形的面积。面积大于0,则往下加。然后增加宽度,先计算宽为1到i的,然后计算2-i的。而内层循环则计算宽度一定而长度变化的长方形的面积。面积大于0才加入下面的面积计算。在算的过程中求出最大的面积。三层循环。

源代码:

#include <iostream>

#include <stdio.h>

#include <string.h>

using namespace std;

 

int main()

{

   intsum[105][105];

   intn,a;

   while(cin>>n)

   {

     memset(sum,0,sizeof(sum));

     for(int i = 1;i <= n;i++)

        for(int j = 1;j <= n;j++)

        {

          scanf("%d",&a);

          sum[i][j] = sum[i][j-1]+a;

        }

 

     intans = -1;

     intmx = -0x3f3f3f3f;

     for(int i = 1;i <= n;i++)

        for(int j = 1;j <= i;j++)

        {

          ans = -1;

          for(int k = 1;k <= n;k++)

          {

             if(ans< 0)

               ans = sum[k][i] -sum[k][j-1];

             else

               ans += sum[k][i] -sum[k][j-1];

 

             if(ans> mx)

               mx = ans;

          }

        }

     printf("%d\n",mx);

   }

   return0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值