HDU1405 The Last Practice【筛选法】

The Last Practice

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13107 Accepted Submission(s): 3064

Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input
60
12
-1

Sample Output
Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Hint

60=22*31*51

Author
lcy

Source
杭电ACM集训队训练赛(IV)

问题链接HDU1405 The Last Practice
问题简述:给定正整数n,输出其因子以及幂。
问题分析:先用筛选法获得必要的素数备用,然后用素数去除n获得因子和幂。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1405 The Last Practice */

#include <bits/stdc++.h>

using namespace std;

const int N = 65536;
bool isprime[N + 1];
int prime[N / 3], pcnt = 0;
// 欧拉筛法
void eulersieve(void)
{
    memset(isprime, true, sizeof(isprime));

    isprime[0] = isprime[1] = false;
    for(int i = 2; i <= N; i++) {
        if(isprime[i])
            prime[pcnt++] = i;
        for(int j = 0; j < pcnt && i * prime[j] <= N; j++) {  //筛选
            isprime[i * prime[j]] = false;
            if(i % prime[j] == 0) break;
        }
    }
}

int cnt[N / 3];

int main()
{
    eulersieve();

    int n, caseno = 0;
    while(~scanf("%d", &n) && n > 0) {
        memset(cnt, 0, sizeof(cnt));

        for(int i = 0; i < pcnt; i++) {
            while(n % prime[i] == 0)
                cnt[i]++, n /= prime[i];
            if(n == 1) break;
        }

        if(caseno) printf("\n");
        printf("Case %d.\n", ++caseno);
        for(int i = 0; i < pcnt; i++)
            if(cnt[i]) printf("%d %d ", prime[i], cnt[i]);
        printf("\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值