Bailian4116 拯救行动【优先搜索】

4116:拯救行动
总时间限制: 1000ms 内存限制: 65536kB
描述
公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入
第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入
1、两个整数代表N和M, (N, M <= 200).
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#“代表墙壁。
输出
如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible”
样例输入
2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@
样例输出
13
7

问题链接Bailian 拯救行动
问题简述:(略)
问题分析:使用优先搜索来解决,用优先队列来实现,其他都是套路。走一格,如果没有守卫则只需要1个单位时间,如果有守卫则需要2个单位时间。因为是求最优解的问题,需要用优先搜索,即先试着从那些到目前为止时间花费最少的情况往下走,才有可能找到最优解。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* Bailian4116 拯救行动 */

#include <bits/stdc++.h>

using namespace std;

const int N = 200;
char b[N][N + 1];
bool vis[N][N];
struct Node {
    int row, col, time;
    Node(int r, int c, int t):row(r), col(c),time(t){}
    friend bool operator<(Node a, Node b)
    {
        return a.time > b.time;
    }
};
int dr[] = {-1, 1, 0, 0};
int dc[] = {0, 0, -1, 1};
const int DL = sizeof(dr) / sizeof(int);

int main()
{
    int s, n, m;
    scanf("%d", &s);
    while(s--) {
        priority_queue<Node> q;

        scanf("%d%d", &n, &m);
        getchar();
        for(int i = 0; i < n; i++)
            scanf("%s", b[i]);

        memset(vis, false, sizeof(vis));
        int tr, tc, cnt = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                if(b[i][j] == 'r') {
                    q.push(Node(i, j, 0));
                    vis[i][j] = true;
                    if(++cnt == 2) break;
                } else if(b[i][j] == 'a') {
                   tr = i;
                   tc = j;
                   if(++cnt == 2) break;
                }

        while(!q.empty()) {
            Node t = q.top();
            if(t.row == tr && t.col == tc) break;
            q.pop();
            for(int i = 0; i < DL; i++) {
                int nrow = t.row + dr[i];
                int ncol = t.col + dc[i];
                if(nrow < 0 || nrow >= n || ncol < 0 || ncol >= m)
                    continue;
                if(vis[nrow][ncol] || b[nrow][ncol] == '#')
                    continue;
                vis[nrow][ncol] = true;
                if(b[nrow][ncol] == 'x')
                    q.push(Node(nrow, ncol, t.time + 2));
                else if(b[nrow][ncol] == '@' || b[nrow][ncol] == 'a')
                    q.push(Node(nrow, ncol, t.time + 1));
            }
        }

        if(q.empty())
            puts("Impossible");
        else
            printf("%d\n", q.top().time);
    }

    return 0;
}
  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值