HDU1673 POJ3632 Optimal Parking【最值】

509 篇文章 6 订阅
73 篇文章 3 订阅

Optimal Parking
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3499 Accepted Submission(s): 2929

Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.

Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.

Sample Input
2
4
24 13 89 37
6
7 30 41 14 39 42

Sample Output
152
70

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)

问题链接HDU1673 POJ3632 Optimal Parking
问题简述:一条路上有n家商店,给定坐标。某人停车在某点后,要逛完所有商店回到车里。停车地点自选,求最少需要步行多远。
问题分析:车停在最近和最远位置之间,步行最少。但是,最近到最远之间的街道需要走2遍。用排序来实现不是好办法,慢。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1673 POJ3632 Optimal Parking */

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int t, n, x;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        int minx = 99 + 1, maxx = 0;
        while(n--) {
            scanf("%d", &x);

            minx = min(minx, x);
            maxx = max(maxx, x);
        }

        printf("%d\n", (maxx - minx) * 2);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值