POJ3615 Cow Hurdles【Floyd算法】

Cow Hurdles
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10362 Accepted: 4419

Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows’ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1…N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1…M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

Input

  • Line 1: Three space-separated integers: N, M, and T
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi
  • Lines M+2…M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

  • Lines 1…T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output

4
8
-1

Source

USACO 2007 November Silver

问题链接POJ3615 Cow Hurdles
问题简述:(略)
问题分析:Floyd算法的变种,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ3615 Cow Hurdles */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

/* Floyd-Warshall算法:计算图中任意2点之间的最短距离
 * 复杂度:O(N×N×N)
 * 输入:n 全局变量,图结点数
 *      g 全局变量,邻接矩阵,g[i][j]表示结点i到j间的边距离
 * 输出:g 全局变量
 */
const int INF = 0x3f3f3f3f;
const int N = 300 + 1;
int g[N][N], n;

void floyd()
{
    for(int k = 1; k <= n; k++)
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                if (g[i][j] > g[i][k] && g[i][j] > g[k][j])
                    g[i][j] = g[i][k] > g[k][j] ? g[i][k] : g[k][j];
}

int main()
{
    int m, t;
    while (~scanf("%d%d%d", &n, &m, &t)) {
        memset(g, INF, sizeof g);
        for(int i = 1; i <= N; i++) g[i][i] = 0;

        int u, v, w;
        for (int i  = 1; i <= m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            g[u][v] = min(g[u][v], w);
        }

        floyd();

        for (int i = 1; i <= t; i++) {
            scanf("%d%d", &u, &v);
            printf("%d\n", g[u][v] == INF ? -1 : g[u][v]);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值