POJ2780 Linearity【水题】

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8517 Accepted: 1969

Description

Alice often examines star maps where stars are represented by points in a plane and there is a Cartesian coordinate for each star. Let the Linearity of a star map be the maximum number of stars in a straight line.

For example, look at the star map shown on the figure above, the Linearity of this map is 3, because the star 1, star 2, and star 5 are within the same straight line, and there is no straight line that passes 4 stars.

You are to write a program to find the Linearity of a star map.

Input

Input will contain multiple test cases. Each describes a star map.

For each test case, the first line of the input contains the number of stars N (2 <= N <= 1000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0 <= X, Y <= 1000). There can be only one star at one point of the plane.

Output

Output the Linearity of the map in a single line.

Sample Input

5
0 0
2 0
0 2
1 1
2 2

Sample Output

3

Source


问题链接POJ2780 Linearity

题意简述输入n,输入n个整数对,即n个坐标点,问最多共线点数是多少。

问题分析:用暴力法解决这个问题,好在计算规模不算大。

程序说明

  程序中,判断共线时,使用的是乘法,没有用除法,可以保证精确的计算结果。

  这个问题与POJ1118 HDU1432 Lining Up基本上相同,只是输入数据格式略有不同。


AC的C语言程序如下:

/* POJ2780 Linearity */

#include <stdio.h>

#define MAXN 1000

struct {
    int x, y;
} p[MAXN+1];      /* point */

int main(void)
{
    int n, ans, max, i, j, k;

    while(scanf("%d", &n) != EOF) {
        for(i=0; i<n; i++)
            scanf("%d%d", &p[i].x, &p[i].y);

        ans = 2;
        for(i=0; i<n; i++)
            for(j=i+1; j<n; j++) {
                max = 2;
                for(k=j+1; k<n; k++)
                    if ((p[j].x - p[i].x)*(p[k].y - p[j].y) == (p[j].y - p[i].y)*(p[k].x - p[j].x))
                        max++;
                if(max > ans)
                    ans = max;
            }

        printf("%d\n", ans);
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值