UVA673 Parentheses Balance【堆栈+输入流】

  You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a) if it is the empty string

(b) if A and B are correct, AB is correct,

(c) if A is correct, (A) and [A] is correct.

  Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string a line.

Output

A sequence of ‘Yes’ or ‘No’ on the output file.

Sample Input

3

([])

(([()])))

([()[]()])()

Sample Output

Yes

No

Yes


问题链接UVA673 Parentheses Balance

问题简述参见上文。

问题分析

  这个是一个括号匹配问题,自然需要用堆栈

程序说明

  输入方面用字符流是最佳的方案。

  堆栈就没有必要用STL的堆栈(时间上慢),自己简单用数组实现一个堆栈是轻而易举的事情。

题记:(略)

参考链接:(略)


AC的C语言程序如下:

/* UVA673 Parentheses Balance */

#include <stdio.h>

#define N 128

char stack[N];
int ps;

int main(void)
{
    int n;
    char c;

    scanf("%d", &n);
    getchar();
    while(n--) {
        ps = 0;
        while((c = getchar()) != '\n') {
            if(ps > 0) {
                if((stack[ps - 1] == '(' && c == ')') || (stack[ps - 1] == '[' && c == ']'))
                    ps--;
                else
                    stack[ps++] = c;
            } else
                stack[ps++] = c;
        }

        printf("%s\n", (ps > 0) ? "No" : "Yes");
    }

    return 0;
}

AC的C++语言程序如下:

/* UVA673 Parentheses Balance */

#include <iostream>
#include <stack>

using namespace std;

int main()
{
    int n;
    char c;

    scanf("%d", &n);
    getchar();
    while(n--) {
        stack<char> s;

        while((c = getchar()) != '\n') {
            if(s.empty())
                s.push(c);
            else {
                if((s.top() == '(' && c == ')') || (s.top() == '[' && c == ']'))
                    s.pop();
                else
                    s.push(c);
            }
        }

        printf("%s\n", s.empty() ? "Yes" : "No");
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值