UVALive5402 UVA579 Clock Hands【水题】

  The medieval interest in mechanical contrivances is well illustrated by the development of the mechanical
clock, the oldest of which is driven by weights and controlled by a verge, an oscillating arm engaging
with a gear wheel. It dates back to 1386.
  Clocks driven by springs had appeared by the mid-15th century, making it possible to con- struct
more compact mechanisms and preparing the way for the portable clock.
  English spring-driven pendulum clocks were first commonly kept on a small wall bracket and later
on a shelf. Many bracket clocks contained a drawer to hold the winding key. The earliest bracket clocks,
made for a period after 1660, were of architectural design, with pillars at the sides and a pediment on
top.
  In 17th- and 18th-century France, the table clock became an object of monumental design, the best
examples of which are minor works of sculpture.
  The longcase clocks (also called grandfather clocks) are tall pendulum clock enclosed in a wooden
case that stands upon the floor and is typically from 6 to 7.5 feet (1.8 to 2.3 m) in height. Later, the
name “grandfather clock” became popular after the popular song “My Grandfather’s Clock,” written
in 1876 by Henry Clay Work.
  One of the first atomic clocks was an ammonia-controlled clock. It was built in 1949 at the National
Bureau of Standards, Washington, D.C.; in this clock the frequency did not vary by more than one
part in 108.
  Nuclear clocks are built using two clocks. The aggregate of atoms that emit the gamma radiation of
precise frequency may be called the emitter clock; the group of atoms that absorb this radiation is the
absorber clock. One pair of these nuclear clocks can detect energy changes of one part in 1014, being
about 1,000 times more sensitive than the best atomic clock.
  The cesium clock is the most accurate type of clock yet developed. This device makes use of
transitions between the spin states of the cesium nucleus and produces a frequency which is so regular
that it has been adopted for establishing the time standard.
  The history of clocks is fascinating, but unrelated to this problem. In this problem, you are asked
to find the angle between the minute hand and the hour hand on a regular analog clock. Assume that
the second hand, if there were one, would be pointing straight up at the 12. Give all angles as the
smallest positive angles. For example 9:00 is 90 degrees; not -90 or 270 degrees.
Input
The input is a list of times in the form ‘H:M’, each on their own line, with 1 ≤ H ≤ 12 and
00 ≤ M ≤ 59. The input is terminated with the time ‘0:00’. Note that H may be represented with 1
or 2 digits (for 1–9 or 10–12, respectively); M is always represented with 2 digits (the input times are
what you typically see on a digital clock).
Output
The output displays the smallest positive angle in degrees between the hands for each time. The answer
should between 0 degrees and 180 degrees for all input times. Display each angle on a line by itself in
the same order as the input. The output should be rounded to the nearest 1/1000, i.e., three places
after the decimal point should be printed.
Sample Input
12:00
9:00
8:10
0:00
Sample Output
0.000
90.000
175.000


Regionals 1997 >> North America - East Central NA


问题链接UVALive5402 UVA579 Clock Hands

问题简述计算时钟时针和分针的夹角。

问题分析数学计算题,按角度计算即可。

程序说明:(略)

题记:(略)


参考链接:(略)


AC的C语言程序如下:

/* UVALive5402 UVA579 Clock Hands */

#include <stdio.h>

int main(void)
{
    int h, m;
    while (scanf("%d:%d", &h, &m) != EOF && (h || m)) {
        double m2 = m * 6.0;
        double h2 = h * 30.0 + m * 0.5;
        double a = h2 - m2;
        if (a <  0)
            a += 360.0;
        if (a > 180)
            a = 360.0 - a;
        printf("%.3lf\n", a);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值