UVA11401 Triangle Counting【递推】

You are given n rods of length 1, 2, . . . , n. You have to pick any 3 of them and build a triangle. Howmany distinct triangles can you make? Note that, two triangles will be considered different if they haveat least 1 pair of arms with different length.

Input

The input for each case will have only a single positive integer n (3 ≤ n ≤ 1000000). The end of inputwill be indicated by a case with n < 3. This case should not be processed.

Output

For each test case, print the number of distinct triangles you can make.

Sample Input

5

8

0

Sample Output

3

22


问题链接UVA11401 Triangle Counting

问题简述:(略)

问题分析:这是一个递推组合的问题,关键是找出递推函数来。不解释!

程序说明:打表是必要的!还需要注意变量类型!!!

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVA11401 Triangle Counting  */

#include <iostream>
#include <stdio.h>

using namespace std;

typedef long long LL;

const int N = 1e6;
LL f[N + 1];

void maketable()
{
    f[0] = 0;
    f[1] = 0;
    f[2] = 0;
    f[3] = 0;

    for(LL i=4; i<=N; i++)
        f[i] = f[i - 1] + ((i - 1) * (i - 2) / 2 - (i - 1) / 2) / 2;
}


int main()
{
    maketable();

    LL n;
    while(~scanf("%lld", &n) && n) {
        if(n < 3)
            break;

        printf("%lld\n", f[n]);
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值