HDU1031 ZOJ2511 Design T-Shirt【水题+排序】

232 篇文章 0 订阅
73 篇文章 3 订阅

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11066    Accepted Submission(s): 5330


Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
 
 
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
 
 
6 5 3 1 2 1
 

Author
CHEN, Yue
 

Source

问题链接HDU1031 ZOJ2511 Design T-Shirt

问题简述:对n个人进行m件T恤衫满意度调查,按编号降序输出满意度前k大的编号。

问题分析

  这是一个排序问题,对结构题进行排序

  首先,统计对m件T恤的满意度,并且进行排序。

  然后,对满意度高的k件T恤再进行按序号排序,就得到所需要的编号。

  需要注意的是,这个题有个坑啊,没有说m最大是多大,程序中只好设为10000。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1031 ZOJ2511 Design T-Shirt */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 10000;

struct _node {
    int no;
    double val;
} a[N];

bool cmp1(_node a, _node b)
{
    return a.val > b.val;
}

bool cmp2(_node a, _node b)
{
    return a.no > b.no;
}

int main()
{
    int n, m, k;

    while(~scanf("%d%d%d", &n, &m, &k)) {
        // 初始化
        memset(a, 0, sizeof(a[0]) * m);

        // 读入数据
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++) {
                a[j].no = j;

                double v;
                scanf("%lf", &v);
                a[j].val += v;
            }

        // 排序
        sort(a, a + m, cmp1);
        sort(a, a + k, cmp2);

        // 输出结果
        for(int i=0; i<k; i++) {
            if(i != 0)
                printf(" ");
            printf("%d", a[i].no + 1);
        }
        printf("\n");
    }

    return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值