HDU:1031 Design T-Shirt

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8872    Accepted Submission(s): 4255

题目链接
Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
  
  
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
  
  
6 5 3 1 2 1
题目意思:
有一个人负责给大家设计T恤衫,总共有N个人给出了M种设计,让从这M种设计中挑出K种使所有人的满意度尽可能大(即要选择满意度最大的K中设计)。
输入:
第一行输入N,M,K,代表N个人,M种设计,从中挑K种,然后接下来的N行,分别给出第1~N个人对每一个设计的满意度,
即第I行第J个代表第I个人对第J种设计的满意度。
输出:
如果答案有多个,要求对应下标小的那一种答案,并将答案以非升序的方法输出。
两个数之前有一个空格,最后一个数后无空格

     
     
#include<iostream>
#include<stdio.h>
#include<set>
#include<string.h>
#include<cmath>
#include<algorithm>

using namespace std;

struct design
{
    int index;
    double sat;
}a[1000000];
bool cmp(design d1,design d2)
{
    if(d1.sat == d2.sat)  ///满意度相等,则要按序号小的排在后面
        return d1.index > d2.index;
    else
        return d1.sat < d2.sat;    ///否则按满意度递增排序
}
int b[1000000];    
int main()
{
    int N,M,K,i,j,k;  ///N个人,M个设计,取K个
    while(~scanf("%d%d%d",&N,&M,&K))
    {
        for(i = 1; i <= M; i++)  ///第i个设计的序号为i,满意度初始化为0.
        {
            a[i].index = i;
            a[i].sat=0;
        }
        for(i = 1; i <= N; i++)
            for(j = 1; j <= M; j++)
            {
                double temp;
                scanf("%lf",&temp);
                a[j].sat += temp;   ///第i个人对第j个设计的满意度
            }
        sort(a+1,a+M+1,cmp);      ///对满意度排序
        k = 0;
        for(i = M; k < K; i--)    ///求取下标
        {
            b[k] = a[i].index;
            k++;
        }
        sort(b,b+K);   ///对下标进行排序
        for(i = K-1; i > 0; i--)   ///逆序输出K个下标
            printf("%d ",b[i]);
        printf("%d\n",b[0]);
    }
    return 0;
}




  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值