POJ1363 ZOJ1259 UVA514 UVALive5531 Rails【堆栈+stack】

509 篇文章 9 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37013 Accepted: 14343

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.  

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.  

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.  

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

Source


Regionals 1997 >> Europe - Central


问题链接POJ1363 ZOJ1259 UVA514 UVALive5531 Rails

问题简述

  某城市有一个火车站,有n节车厢从A方向驶入车站,按进站的顺序编号为1-n.你的任务是判定能否按照给定的顺序进入B方向驶出车站。

问题分析

  使用堆栈进行处理即可,需要考虑一些程序细节。驶入车厢号的顺序是1...n,与驶出要求进行匹配即可,匹配方法有多种。

  方法一:

  每次驶入车厢号总是先进栈,然后尽可能多地匹配栈顶与出站顺序。这个逻辑最为简洁易懂。

  方法二和方法三:

  每次驶入车厢号与出站顺序进行匹配,暂时匹配不了则试着用堆栈顶的车厢号进行匹配,并且将车厢号推入堆栈中。这种匹配逻辑写出代码稍微复杂一些。方法二和方法三思路相同,只是其中一个用了STL的堆栈容器stack,另外一个则使用自己编写的堆栈数据结构。不用STL的程序,速度上应该是要稍微快一些。

程序说明

  给出三种程序代码,代码技巧略有不同,不解释。

题记:(略)

参考链接:(略)


AC的C++语言程序(方法一)如下:

/* POJ1363 ZOJ1259 UVA514 UVALive5531 Rails */

#include <iostream>
#include <stack>
#include <stdio.h>

using namespace std;

const int N = 1000;
int target[N];

int main()
{
    int n;
    while(~scanf("%d", &n) && n) {
        for(;;) {
            stack<int> s;

            scanf("%d", &target[0]);
            if(target[0] == 0)
                break;
            for(int i=1; i<n; i++)
                scanf("%d", &target[i]);

            int head=0;
            for(int num=1; num<=n; num++) {
                s.push(num);
                while(!s.empty() && s.top() == target[head])
                    s.pop(), head++;
            }

            printf("%s\n", s.empty() ? "Yes" : "No");
        }
        printf("\n");
    }
}


AC的C++语言程序(方法二)如下:

/* POJ1363 ZOJ1259 UVA514 UVALive5531 Rails */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 1000;
int target[N], head, stack[N], top;

int main()
{
    int n;
    while(~scanf("%d", &n) && n) {
        for(;;) {
            scanf("%d", &target[0]);
            if(target[0] == 0)
                break;
            for(int i=1; i<n; i++)
                scanf("%d", &target[i]);

            int head =  top = 0;
            int num = 1;
            while(head < n) {
                if(num == target[head])
                    num++, head++;
                else if(top > 0 && stack[top - 1] == target[head])
                    top--, head++;
                else if(num <=n)
                    stack[top++] = num++;
                else
                    break;
            }

            printf("%s\n", head == n ? "Yes" : "No");
        }
        printf("\n");
    }

    return 0;
}



AC的C++语言程序(方法三)如下:

/* POJ1363 ZOJ1259 UVA514 UVALive5531 Rails */

#include <iostream>
#include <stack>
#include <stdio.h>

using namespace std;

const int N = 1000;
int target[N];

int main()
{
    int n;

    while(~scanf("%d", &n) && n) {
        for(;;) {
            stack<int> s;

            scanf("%d", &target[0]);
            if(target[0] == 0)
                break;
            for(int i=1; i<n; i++)
                scanf("%d", &target[i]);

            int head = 0, num = 1;
            while(head < n) {
                if(num == target[head])
                    num++, head++;
                else if(!s.empty() && s.top() == target[head])
                    s.pop(), head++;
                else if(num <= n)
                    s.push(num++);
                else
                    break;
            }

            printf("%s\n", head == n ? "Yes" : "No");
        }
        printf("\n");
    }

    return 0;
}





  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值