UVA210 UVALive5149 Concurrency Simulator【模拟】

281 篇文章 4 订阅
96 篇文章 5 订阅

Programs executed concurrently on a uniprocessor system appear to be executed at the same time, but in reality the single CPU alternates between the programs, executing some number of instructions from each program before switching to the next. You are to simulate the concurrent execution of up to ten programs on such a system and determine the output that they will produce.

  The program that is currently being executed is said to be running, while all programs awaiting execution are said to be ready. A program consists of a sequence of no more than 25 statements, one per line, followed by an end statement. The statements available are listed below.

Statement Type               Syntax

Assignment                     variable = constant

Output                            print variable

Begin Mutual Exclusion   lock

End Mutual Exclusion      unlock

Stop Execution                end

A variable is any single lowercase alphabetic character and a constant is an unsigned decimal number less than 100. There are only 26 variables in the computer system, and they are shared among the programs. Thus assignments to a variable in one program affect the value that might be printed by a different program. All variables are initially set to zero.

  Each statement requires an integral number of time units to execute. The running program is permitted to continue executing instructions for a period of time called its quantum. When a program's time quantum expires, another ready program will be selected to run. Any instruction currently being executed when the time quantum expires will be allowed to complete.

  Programs are queued first-in-first-out for execution in a ready queue. The initial order of the ready queue corresponds to the original order of the programs in the input file. This order can change, however, as a result of the execution of lock and unlock statements.

  The lock and unlock statements are used whenever a program wishes to claim mutually exclusive access to the variables it is manipulating. These statements always occur in pairs, bracketing one or more other statements. A lock will always precede an unlock, and these statements will never be nested. Once a program successfully executes a lock statement, no other program may successfully execute a lock statement until the locking program runs and executes the corresponding unlock statement. Should a running program attempt to execute a lock while one is already in effect, this program will be placed at the end of the blocked queue. Programs blocked in this fashion lose any of their current time quantum remaining. When an unlock is executed, any program at the head of the blocked queue is moved to the head of the ready queue. The first statement this program will execute when it runs will be the lock statement that previously failed. Note that it is up to the programs involved to enforce the mutual exclusion protocol through correct usage of lock and unlock statements. (A renegade program with no lock/unlock pair could alter any variables it wished, despite the proper use of lock/unlock by the other programs.)

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

  The first line of the input file consists of seven integers separated by spaces. These integers specify (in order): the number of programs which follow, the unit execution times for each of the five statements (in the order given above), and the number of time units comprising the time quantum. The remainder of the input consists of the programs, which are correctly formed from statements according to the rules described above.

  All program statements begin in the first column of a line. Blanks appearing in a statement should be ignored. Associated with each program is an identification number based upon its location in the input data (the first program has ID = 1, the second has ID = 2, etc.).

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

  Your output will contain of the output generated by the print statements as they occur during the simulation. When a print statement is executed, your program should display the program ID, a colon, a space, and the value of the selected variable. Output from separate print statements should appear on separate lines.

Sample Input

1

3 1 1 1 1 1 1

a = 4

print a

lock

b = 9

print b

unlock

print b

end

a = 3

print a

lock

b = 8

print b

unlock

print b

end

b = 5

a = 17

print a

print b

lock

b = 21

print b

unlock

print b

end

Sample Output

1: 3

2: 3

3: 17

3: 9

1: 9

1: 9

2: 8

2: 8

3: 21

3: 21


World Finals >> 1991 - San Antonio

问题链接UVA210 UVALive5149 Concurrency Simulator

问题简述:(略)

问题分析

  占个位置,不解释。

  样例数据有毒,原题的输入部分少个1。这里已经修改。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVA210 UVALive5149 Concurrency Simulator */

#include <bits/stdc++.h>

using namespace std;

const int N = 5;
vector<string> statement[N];
bool lock2;
int vars[26], proc[1000], t[N];
int q;

deque<int> waiting;
queue<int> blocked;

void run(int i)
{
    int runtime = q, v;
    while(runtime > 0) {
        string cmd = statement[i][proc[i]];
        if(cmd[2] == '=') { // Assignment : variable = constant
            runtime -= t[0];
            v = cmd[4] - '0';
            if(cmd.size() == 6)
                v = v*10 + cmd[5] - '0';
            vars[cmd[0] - 'a'] = v;
        } else if(cmd[2] == 'i') {  // Output : print variable
            runtime -= t[1];
            printf("%d: %d\n", i, vars[cmd[6] - 'a']);
        } else if(cmd[2] == 'c') {  // Begin Mutual Exclusion : lock
            runtime -= t[2];
            if(lock2) {
                blocked.push(i);
                return;
            } else
                lock2 = true;
        } else if(cmd[2] == 'l') {  // End Mutual Exclusion : unlock
            lock2 = false;
            runtime -= t[3];
            if(!blocked.empty()) {
                v = blocked.front();
                blocked.pop();
                waiting.push_front(v);
            }
        } else  // Stop Execution : end
            return;
        ++proc[i];
    }
    waiting.push_back(i);
}

int main()
{
    int casenum;
    scanf("%d", &casenum);
    while(casenum--) {
        int n;
        scanf("%d", &n);
        for(int i=0; i<N; i++)
            scanf("%d", &t[i]);
        scanf("%d",&q);
        getchar();
        for(int i=1; i<=n; i++) {
            statement[i].clear();

            string s;
            while(getline(cin, s)) {
                statement[i].push_back(s);
                if(statement[i].back()=="end")break;
            }
            waiting.push_back(i);
        }

        memset(proc, 0, sizeof(proc));
        memset(vars, 0, sizeof(vars));
        while(!waiting.empty()) {
            int curr = waiting.front();
            waiting.pop_front();
            run(curr);
        }
        if(casenum)
            printf("\n");
    }

    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值