POJ2249 ZOJ1938 UVA530 Binomial Showdown【组合计算】

509 篇文章 6 订阅
232 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20690 Accepted: 6366

Description

In how many ways can you choose k elements out of n elements, not taking order into account?  
Write a program to compute this number.

Input

The input will contain one or more test cases.  
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).  
Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2 31.  
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.  

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816

Source


问题链接POJ2249 ZOJ1938 UVA530 Binomial Showdown

问题简述:(略)

问题分析

  这个问题就是一个组合函数C(n,k)。

  需要注意2点,一是尽可能计算量要小,二是计算过程中避免出现溢出。

  后一点是关键,参见参考链接。

程序说明:(略)

题记:(略)

参考链接HDU2519 新生晚会【组合计算】


AC的C++语言程序如下:
/* POJ2249 ZOJ1938 UVA530 Binomial Showdown */

#include <iostream>
#include <stdio.h>

using namespace std;

typedef long long LL;

// 计算组合函数:n中取m
LL c(int n, int m)
{
    LL c;

    if(n < m)
        c=0;
    else if (n == m || m == 0)
        c=1;
    else {
        c = 1;
        n = n - m + 1;
        for (int i=1; i<=m; i++) {
            c *= n++;
            c /= i;
        }
    }

    return c;
}

int main()
{
    LL n, k;
    while(~scanf("%lld%lld", &n, &k) && (n || k)) {
        if(n - k < k)
            k = n - k;
        printf("%lld\n", c(n, k));
    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值